1

I am trying to setup search in my SharePoint 2013 site, using BCS, connecting to a .Net assembly which is exposing the types.

The first time I deployed the solution, the exposed types came up as crawled properties, and I was able to map them to managed properties, and I could search successfully.

However, after I added a few more types to my .Net assembly, these are not coming up in the crawled properties. Any changes I make to my .Net assembly does not seem to bring up the properties.

How can I resolve this?

edit I removed the Content source and the external content type, and then deployed my solution again; then I created the content source again and did a full crawl; still, I couldn't see the crawled property

  • did you perform the IIS reset after Updates? – Waqas Sarwar MVP Apr 24 '15 at 13:52
  • Yes, I tried iisreset multiple times. Also, tried Restart-Service spsearchhostcontroller as I had read somewhere. – rohinMVP Apr 24 '15 at 14:04
  • did you reimport the assembly? – Waqas Sarwar MVP Apr 24 '15 at 14:07
  • Does your new exposed types have a value.? Crawled properties will be created only if has at least one value (can't be blank). Reindex or full crawl is also required. – Marko Tica Apr 24 '15 at 14:38
  • yes, they have value. Actually, two of them are mandatory date fields.. – rohinMVP Apr 24 '15 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.