0

As a site administrator for my team I decided to abandon the left side quick links bar. I took the following steps to do that:

  • From Site Settings, I disabled the quick links bar after removing all links from 'Current view'
  • To get the empty space (where the quick links had been), I created a new page and added a Content Editor web part. I linked this web part to a text file containing CSS.

The code in the text file is as follows:

    <style type="text/css">
    #s4-leftpanel {display: none}
    .s4-ca {margin-left: 0px}
    </style>

When I designated this new page as the home page, suddenly a list called 'Recently modified' appeared where the quick links had been. After some research I found some additional code to get rid of the 'Recently modified' list:

    <style type="text/css">
    .s4-recentchanges
    {display:none}
    </style>

So the text file the Content Editor web part is linked to consists of the following code now:

    <style type="text/css">
    #s4-leftpanel {display: none}
    .s4-ca {margin-left: 0px}
    </style>
    <style type="text/css">
    .s4-recentchanges
    {display:none}
    </style>

This seemed to work just fine at first. Until I checked the team site on the pc of a colleague (a 'regular' user) from my team. The quick links and 'Recently modified' list were hidden, but the empty space was still there. I do not understand how this is possible.

The Content Editor solution is my only way to go, because I am not authorized to make any changes to the master page. Nor do I have access to Sharepoint Designer.

I really hope somebody can help me out here. Disabling the quick links has no point when my team members can't have the entire screen width anyway. Thank you already!

  • try adding the !important directive after all of your css rules and see if that resolves the issue. Also, make sure it's not a cache issue with your colleague's browser. As a final check, hit F12 on her browser and see if your rule (margin-left:0px) gets applied – MdMazzotti Apr 24 '15 at 13:04
  • Sp2013 or 2010? – Christoffer Apr 24 '15 at 13:07
0

This seems similar to this other question.

By looking at your styles, I would say that you have an SP2010 site and the styles are matching properly.

The possible caveats are:

a) you will have to add the CEWP on each page

b) your css file may not fully checked in and/or published so that all users can see it (or the page itself)

c) if you have anything else custom (e.g. html), it may cause the styles to fail to apply properly

  • 1
    Wow Tiago, thank you a million times! I'm opting for option b): the css file was not checked in and published! I have been trying to figure this out all day and it was driving me to newly found depths of despair. You made my day man! – Michiel Brouwer Apr 24 '15 at 13:45
  • feel free to set this as the marked answer, then! – Tiago Duarte Apr 24 '15 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.