Recently SharePoint has started completely ignoring the filtering criteria in the list view for the Tasks list on my site. For testing, I created a list view with the filter "Show only when the column id is equal to 11." When I look at the list with this view, I see all items in the list although clearly only one should have an ID of 11.

Even the built-in views (Upcoming, Late Tasks, etc.) show all items, though other options like column selection are applied.

Other lists on the same site do not seem to be affected by this issue and if I apply the filters using something like CamlDesigner, I get back the correct (filtered) results.

1 Answer 1


This is a known issue with MS15-022 and the March 2015 CU.


Simply add a Style (any will do, except the default one) to the View, and it will be resolved. Alternative option is to enable Server Render if displaying the Task List in a Webpart.

  • It seems these two solutions (another style or enable Server Render) both disable the "Search this list" feature, which we use heavily. Is there another solution?
    – russds
    May 8, 2015 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.