i have created a Application page in pages library,and i have selected my content type then choosed a custom page layout .And i clicked to create a page ,its taking time to load and i m getting error like"This page is not using a valid page layout. To correct the problem, edit page settings and select a valid page layout." " Any one faced this issue?

1 Answer 1


There are two potential resolutions for this.

If the page was working at some point in time, use Version History to revert to the last known working version:

  • Go to Site Actions -> View All Site Content.
  • Click Pages.
  • Click the dropdown menu next to the .aspx page in question.
  • Select Version History.
  • Preview older versions to see if the issue was recently introduced. If possible, identify a last-known working version, and suggest the customer restore that version.

Alternatively, we can try to manually try to fix the page layout:

You may find in Site Content and Structure (/_layouts/sitemanager.aspx) that the Page Layout is listed by path, as opposed to by name. For example, the layout is listed as "/_catalogs/masterpage/WelcomeLinks.aspx" instead of "Welcome page with summary links".

First, we will want to ensure the template is enabled in /_layouts/AreaTemplateSettings.aspx. Typically, Page Layouts is set to "Pages in this site can use any layout".

Then we will want to go to View All Site Content (/_layouts/viewlsts.aspx) -> Pages, click the dropdown on the affected page and select "Edit page properties". From here, select a valid layout. You should now be able to render the page.

We sometimes have force the page layout to reset, by changing it to something else, then back to the original layout in both viewlsts.aspx and sitemanager.aspx:

  • Go to /_layouts/viewlsts.aspx -> Pages -> Edit page properties of the affected page and change the layout to something else.
  • Go to /_layouts/sitemanager.aspx -> Pages -> Edit page settings of the affected page and change the layout to the same as Step 1.
  • Go back to viewlsts.aspx and change the layout to the original.
  • Go back to sitemanager.aspx and change the layout back to the original.
  • Confirm the layout in sitemanager.aspx now displays by Name, not path.
  • Confirm the page no longer throws errors.

Reference: Microsoft Knowledge base Article

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.