0

I installed SharePoint with my student account on campus, which has only read permission. Here are some problems.

  1. What kind of permission do I need to install and configure Sharepoint, for now I use my student account that given full control of the server computer that I work on. But it seems like I could not do anything in Active Directory(Add role, modify role etc.)

  2. Will it work if I use the same account for both SQL and SharePoint since it's the only account that I have.

  3. When I install workflow manager, I tried to use my account as run as account it showed it was invalid. But it worked if I use a local account that I created it on the machine. But have problem when I put commend on PowerShell:

enter image description here

This is the command that I entered. But when I opened the site it gave me error like follow:

AuthorizationErrorThe caller does not have the necessary permissions required for this operation. Permissions granted: None. Required permissions: ReadScope.

2
  • did you install the SharePoint in you'r local machine as a single farm?
    – Marco
    Commented Apr 22, 2015 at 13:51
  • Yes, I think so.
    – Tote
    Commented Apr 22, 2015 at 14:08

2 Answers 2

0

Install account require:

  1. It must have domain user account permissions.
  2. It must be a member of the local administrators group on each server in the SharePoint farm.
  3. This account must have access to the SharePoint databases.
  4. If you use any Windows PowerShell operations that affect a database, the setup user administrator account must be a member of the db_owner role.
  5. This account must be assigned to the securityadmin and dbcreator SQL Server security roles during setup and configuration.

https://technet.microsoft.com/en-us/library/ee662513.aspx

0

I think you should not have the problem with your account as long as it fullfill this.

  1. Domain Account
  2. Local Admin on the server.

You can install the SharePoint as well as SQL server under the same account, this is only for dev or test farm not recommend for the Production at all.

I dont see any problem with the workflow, could you please share the screen where you get invalid users.

10
  • It displayed "Specified RunAs account is invalid" when I use the domain account that I use for Sharepoint.
    – Tote
    Commented Apr 22, 2015 at 14:07
  • I am sorry, i am missing, could you pleae share the screen shot where you run as account...
    – Waqas Sarwar MVP
    Commented Apr 22, 2015 at 14:14
  • Sorry about the confusing. I was talking about when configure workflow manager, at the point where it required a "RunAs" account, and it did not like my domain account. So I use a local account instead and I suspect that's why I got error when I open the workflow site.
    – Tote
    Commented Apr 22, 2015 at 14:17
  • you are talking about service account? check this technet..2nd image msdn.microsoft.com/en-us/library/jj193514(v=azure.10).aspx
    – Waqas Sarwar MVP
    Commented Apr 22, 2015 at 14:18
  • I followed all the instructions but still failed. And also I have to log in as local account when I configure workflow manager too. If I use domain account but configure local account as service account, it still fails.
    – Tote
    Commented Apr 22, 2015 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.