3

Our SharePoint 2010 farm is being converted to SharePoint 2013. I'm a developer, but not really trained in SharePoint administration. It's my job to wirte the code and get it working. I'm in the process of testing the converted sites.

I am an admin on the SharePoint server and an Intranet Owner on the site. I log onto the server and execute SharePoint Designer 2013 as Admin. I go to Open Site and type in the URL.

I get the message "You can't open this location using this program. Please try a different location."

A different developer on our team is not having this problem. There is no record of an error in the SharePoint logs, or in the Event Logs.

Can anyone point me in the right direction?

3
2

Solved! I brought up the site in SharePoint and went into edit mode on it. It prompted me for my credentials, and then opened the site in in the SharePoint Designer.

Now, when I go into the Designer, that site is on the list of recently used sites and I can click right into edit on it. Apparently, the Designer isn't able to set up the initial connection to the site.

3
  • You mean after your browse the SharePoint site within Windows server, you can open the site with SPD? – Mark L Oct 7 '15 at 7:12
  • Yes. I couldn't make the initial connection from the designer, but I could bring up the designer from the site. Once the connection was defined in Designer, I can bring it up on its own. – Farducci Oct 9 '15 at 0:19
  • strange, but it worked for me too. Thanks – Filip Luchianenco Feb 8 '17 at 22:47
1

Recently I have installed Sharepoint Designer 2013 and tried to connect to SharePoint Online Site. But it dint allow me to login and thrown this below error :

403 forbidden403 forbidden403 forbidden403 forbidden403 forbidden

I am the tenant admin and have all the rights to open site in designer. So there is no issue with the permissions.

The only resolution I found is, updating the designer with ServicePack1.

Here are the links for the service Packs.

SP1 for 32Bit: https://www.microsoft.com/en-us/download/details.aspx?id=42015

SP1 for 64Bit: https://www.microsoft.com/en-us/download/details.aspx?id=42009

Close your designer, install the service pack and re-open it. It works like a charm.!

0
0

According to your post, I assume you can access the SharePoint site in the browser, but you cannot access it in SharePoint Designer 2013. (Validate: That the URL is the same, including but not limited to ensuring the HTTP vs HTTPS is correct.)

I recommend to check your permission in that web site, ensure you have permission to open that web site in SharePoint Designer.

Go to Site Permissions > Permission Level in ribbon > Click the permission you belongs to > Ensure Use Remote Interfaces is selected.

Lastly, you will want to also confirm that you have the functionality enabled in Central Administration.

  1. Open Central Administration, click Application Management tab.

  2. Click User Permissions for Web Application, and make sure the option to Add and Customize Pages is checked/enabled.

1
  • I checked them all, and all the permissions in SharePoint are set correctly. I'm bummed that neither of these suggestions worked. I'll keep experimenting and update the post when I figure it out. Thanks. – Farducci Apr 22 '15 at 17:32
0

You can try to clear cache of a SharePoint designer from the machine you are opening it.

The cache is composed of these 2 folders:

  1. %APPDATA%\Microsoft\Web Server Extensions\Cache
  2. %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache

Just delete the content of these folders.

1
  • I'm running on Windows Server 2012R2. I don't have either of these cache files, or even these directories. – Farducci Apr 22 '15 at 17:30
0

I installed the service pack for SP Designer 2013. The service pack is 32bit, so I had to install the 32bit edition of SP Designer (I originally had 64bit).

Here is the link to the service pack:

https://www.microsoft.com/en-us/download/details.aspx?id=42015

0

I had this issue, until I realise I was not in the "Site collection administrators". Once I added myself to this group I was able to open the site in SharePoint Designer with out issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.