I have a problem accessing the web service ?wsdl for SharePoint lists, although I can see the list of operations.

For example, for the following URLS:

http://team/sites/test/_vti_bin/Lists.asmx - returns a list of operations
http://team/sites/test/_vti_bin/Lists.asmx?WSDL - returns the wsdl document

http://team/sites/test/Lists/TestList1/_vti_bin/Lists.asmx - returns a list of operations
http://team/sites/test/Lists/TestList1/_vti_bin/Lists.asmx?WSDL - returns a 404 error (example of full error pasted below).

I've checked on a few SP installations and I'm seeing the same behaviour on all of them, I've also tried logging on to the web server as admin and calling the pages and I get the same result each time. I've also checked that DisableLoopbackCheck is set to 1 in the registry.

Is it the case that there is no WSDL available for specific lists, just for the generic list type i.e. you get the WSDL from <root>/_vti_bin/Lists.asmx?WSDL and access the actual service via <root>/<Lists>/<MyList>/_vti_bin/Lists.asmx, or have I got the wrong end of the stick here? Do lists have web services all of their own at all?

Any help gratefuly accepted.

--- --- --- Error Text --- --- ---

There was an error downloading 'http://team/sites/test/Lists/Repairs%20Services%20Customer%20Satisfaction%20TEST/_vti_bin/Lists.asmx?wsdl'.
The request failed with HTTP status 404: Not Found.
Metadata contains a reference that cannot be resolved: 'http://team/sites/test/Lists/Repairs Services Customer Satisfaction TEST/_vti_bin/Lists.asmx?wsdl'.
The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'NTLM'.
The remote server returned an error: (401) Unauthorized.
If the service is defined in the current solution, try building the solution and adding the service reference again.

2 Answers 2


You are correct. There is no WSDL available for specific lists. All the operations on the Lists web service are performed against the local SPWeb and take a ListName as a parameter.

  • +1, I would add that @Tim is probably looking for the Lists.GetList method which @MBSurf hinted at.
    – Kit Menke
    Jun 3, 2011 at 13:56
  • Thanks for confirming that MBsurf - this was a question which came from another team who were trying to access the contents of a SP list. I've made a little demo in C# to show them how to access the list they want and get the contents back.
    – Tim
    Jun 6, 2011 at 8:25

make sure u have changed the Class name properly in asmx file

Also check for certificates in your server if u don' have 1 create a new certificate and do the whole process again.....

hope it will help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.