0

I have a SharePoint site with groups Readers,Contributers and Owners. Site is showing "Site Actions" to Owners and Contributers but not reader. If i upgrade a Reader to Contributer, it works fine. Readers can see only something like below (image copied from another question).

enter image description here

However Readers can see "Site Actions" inside "All Site Content" or in any List/Library. Any subsite in my current site shows ribbon fine to visitors.

I have tried it enabling in Navigation settings too but it didn't work.

Any thoughts please?

0

It could be a problem with the SPSecurityTrimmedControl. First, check if the Site Permission Level "Read" has the "View Pages" attribute selected.

If it doesn't help, you can remove the tag "PermissionString" from the masterpage.

<SharePoint:SPSecurityTrimmedControl runat="server" PermissionsString="ViewPages">

  • I have tried this already but it didn't work. Read has View Pages permissions. Is there any way to hide "Site Actions" without changing code and from UI? – Chillax Designs Apr 22 '15 at 13:13
0

So, i found the solution here.

My business users (who were not SP professionals) played with site settings and permissions configurations that resulted in "Site Actions" visibility lost for readers. I followed the below steps and issue resolved for me.

  1. Click on "Site Actions -> Site Permissions"
  2. On the ribbon select the "Permission Tools" tab and press the "Permission
  3. Levels" button under the "Manage" group on the far right
  4. Click on the "Read" Permission Level
  5. Scroll down to the "Personal Permissions" section and check the box for "Manage Personal Views - Create, change, and delete personal views of lists. Press the "Submit" button

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.