0

I am an absolute beginner when it comes to Sharepoint and I am current facing an odd issue right now where one of our AD security group's displayname field is showing up as DOMAIN/accountname :

IncorrectDisplayName - Screenshot

The group is set up exactly the same as the others and are all within the same OU. The group has also been added weeks ago and our user profile import runs daily.

I've tried to run this on our SP server and it appeared to have resolved the issue :

[System.Reflection.Assembly]::Load(“Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c”)
$site = New-Object -TypeName Microsoft.SharePoint.SPSite -ArgumentList http://portal/sites/mysite/default.aspx $group = $site.RootWeb.SiteUsers["NTADMIN\acg-bfs bb adg operations"] $group.Name = "ACG-BFS BB ADG Operations" $group.Update()

However it seems like I'm the only one (admin account) who can see the updated displayname - all other users are still seeing the DOMAIN/accountname. The above method also appears to be tedious as it will have to be run on all site collections.

Can anyone please point me to the right direction?

0

You can resync Display Name using following command

Get-SPUser –Web http://webappurl | Set-SPUser –SyncFromAD

Make sure to run the command using Farm Account.

  • Hi Amal, I could be wrong but I don't think Sharepoint 2007 has powershell commands like the later versions. Is there an equivalent command for this in Sharepoint 2007? – Yad Apr 19 '15 at 13:46
0

You should try updating the property "DisplayName" instead. The suggestion Amal has given works great for users, but not for domain groups (at least thats what my experience tells me).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.