1

I have a SharePoint site where I can edit excel documents using both the SharePoint web app and the excel application installed on my PC.

However, in a new site, I can edit the same excel files using the client application, but not the webapp.

The error that shows up when I click on "Edit in Browser" option is:

"You do not have sufficient permissions to edit this workbook" (see image below)

enter image description here

I think the message is bit misleading as I still can edit them if I click on "Open in Excel" and check the "Edit" option (see image below)

enter image description here

Am I missing a configuration in this new site from my user?

  • Is that document checked out? Can you try with a different document? – Amal Hashim Apr 16 '15 at 0:45
  • @AmalHashim I just created an excel document, uploaded it to the list and tried to edit in browser and got the same error. – John Casablanca Apr 16 '15 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.