3

Any file I uploaded to a SharePoint folder and try to preview it in the browser (either by clicking preview in browser or typing the URL directly into the browser) the browser wants to download the file instead of just displaying it. These are html files. Our Server Administrator does not know what is causing this behavior. HELP!

1
  • 1
    Check your library settings--if the default behavior for documents in a library is to open in client rather than open in a new tab, that'll be the cause.
    – mjacket
    Apr 15, 2015 at 21:19

2 Answers 2

2
  1. Go to Central Administration 2013 > Application Management > Manage Web Application.
  2. Select your web application from the list and on the ribbon select General Settings.
  3. Now find Browser File Handling option in the modal pop up window and change Strict to Permissive.

Just like this

enter image description here

and now you should be able to view your HTML files in browser.

1
  • not work for me ! :( there is no other option ?
    – alireza
    Sep 20, 2017 at 7:24
1

Here is the link where similar kind of question is asked and answered How do I prevent Sharepoint from asking to download html files to my local machine?

You will need to use powershell script to add mime type for HTML file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.