I have a flipbook (generated by http://fliphtml5.com/). It contains a static HTML page with a lot of JavaScript and CSS files. Our users would like to host it on a SharePoint site. The file can be read correctly at local PC with IE.

I have tried to create a publishing page and added a content editor web part to mock the HTML. The reference link to CSS and JS have been corrected. However it still does not work. I believe it is because SharePoint's OOB JavaScript conflicts with the flipbook.

Is there any workaround to host the static HTML page on SharePoint 2013 (on-premise)?

  • Have you tried iFrame?
    – Benny Skogberg
    Commented Apr 14, 2015 at 6:50
  • I don't have a separate web server to host the html. Hence iFrame may not help here.
    – Mark L
    Commented Apr 14, 2015 at 7:26

2 Answers 2


Use Iframe and reference the -tag to a url in a document library that contains your files yourhtml.aspx, yourjs.js, yourrcss.css.

Get your references to scripts and css correct in yourhtml.aspx.

Then just:

<iframe src="https://yoursharepointurl.com/documents/yourhtml.aspx"></iframe>

Use script editor web part, or content editor pointing to a *.txt containing the iframe tag. OR insert code into content editor.

Make sure to rename your *.html to *.aspx OR enable "text/html" as allowed mimetype using powershell. If not SharePoint would want you to download the file instead of opening it.

asnp microsoft.sharepoint.powershell
$webappurl = "https://yoursharepointurl.com"
$mimetype = Read-Host "Enter a mime type:"
$webapp = Get-SPWebApplication $webappurl

You say you don't have a seperate web server. Why would you need one?

  • Thanks for your advice and I almost make it done! When I use iframe method the flipbook is working correctly but the "Fullscreen" button. When I load the html (I renamed to aspx) directly, the flipbook is in full screen but all other JS function are not working.
    – Mark L
    Commented Apr 15, 2015 at 2:07
  • Do you know why I have to use iframe to make the JS loading correctly?
    – Mark L
    Commented Apr 15, 2015 at 2:08
  • 1
    Sorry I have corrected my html! It was because my IE9 render it with IE7 mode. After changing some meta I fixed it! Thanks!
    – Mark L
    Commented Apr 15, 2015 at 7:53
  • Great that it works for you! Commented May 5, 2015 at 8:17

You may put your HTML file and its resources in a basic document Library. In SharePoint, any file can be stored in a doc lib, event HTML code, like HTML pages, CSS files or JavaScript code. SharePoint itself stores (some of) its own aspx, CSS files, etc, in document libraries.

Once your files are all in the doc lib, clicking on the HTML file would simply navigate to it, as if it was an HTML file served by a traditionnal static Web server.

You may also point to that HTML from an IFrame (or a Page Viewer Web part, witch is the same) to get the SharePoint Chrome around your HTML page content.

If the browser prompts to open or save the HTML file instead of navigating to it, try this: in the Central Administration, go to the "Manage web applications" section list, select the Web app in question, open its general settings and change its "Browser File Handling" option to "Permissive".

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post.
    – Waqas Sarwar MVP
    Commented Apr 14, 2015 at 12:34
  • Actually, it does provide an answer, considering that there's no mention in the question of an attempt to do what I suggested. Answering by a question is just a rhetorical manner to show the simplicity of that one.
    – Evariste
    Commented Apr 14, 2015 at 12:39
  • @Evariste, I think you should rephrase your answer to make it more clear that it actually is one. Also provide som details about how to do what you proposes. Commented Apr 14, 2015 at 13:08
  • Done: I've edited the anwser.
    – Evariste
    Commented Apr 14, 2015 at 14:18
  • When I click on the HTML file my IE9 is downloading it. Is there some setting prevent it from render?
    – Mark L
    Commented Apr 15, 2015 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.