0

I have one site on my SharePoint 2013 server where the Quick Edit function of lists seems to be corrupt. For example when a bulk of data is copied from Excel to a list in Quick Edit view the first line is saved and on the second one SharePoint is not able to save the data. I checked all the data in the list and made some tests but nothing worked.

Today I got the issue that when the user of this site adds a task to a tasklist with main and subtasks, SharePoint doesn't save the data (which was inserted manually). I also tested this issue. It seems that SharePoint is not able to save the data cause the "Working on it" screen doesn't disappears:

enter image description here

When I click on "Leave anyway" the data i inserted is in the list.

Has anybody an idea what the error could be or how to find the error? Many thanks in advance!

3
  • Is it a performance issue in the WFE or the SQL Server?
    – Benny Skogberg
    Commented Apr 9, 2015 at 7:48
  • May I know how much RAM is being used in your WFE and SQL Server? Is it a stand-alone or tier architecture? Are you working on production or development? This seems to be a performance issue.
    – Zakir HC
    Commented Apr 9, 2015 at 8:33
  • I'll check this but I don't think that it could be a performance issue cause on other Sites these functions are working. We are using 2 WFE with 32GB for each server. The SQL Servers instance hast 60GB. Commented Apr 9, 2015 at 11:13

2 Answers 2

1

This question is old, but no one ever answered it and the answer applies to SharePoint 2010, 2013, 2016 (and presumably 2019). The problem is most likely caused because of poor database maintenance practices. I recommend following the instructions in this blog (SharePoint Database Maintenance Recommendations) to set up maintenance jobs to: check DB integrity, rebuild the index and update statistics.

0

If you group list or library items in SharePoint Online, the quick edit option is disabled. remove the “Group By” selection by setting it to none. Change the View style to default: Changing view style to “Shaded”, “Newsletter” or something else disables Quick Edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.