1. I can import html files into SharePoint that I have created over time. When I try to import any file with an underscore in the filename or a hyphen in the filename, I get the message that the file has been blocked by the administrator. The administrator has no idea why this is happening.

  2. Any file I uploaded to a SharePoint folder and try to preview it in the browser (either by clicking preview in browser or typing the URL directly into the browser) the browser wants to download the file instead of just displaying it. These are html files.

  3. I try to create a page by using the choice "Pick a preinstalled look", then select a template and click "Try it out" where the next page shows "This is a preview of your site". The box where the preview is shows "the webpage cannot be found".

  • you ask too many questions in single question, which is hard for everybody to answer as well as hard for you mark it as answer. i would recommend split your question in multiple questions.
    – Waqas Sarwar MVP
    Commented Apr 8, 2015 at 17:02

1 Answer 1

  1. SharePoint does not like the special charaters in file name.here are the list of special character ~, #, %, & , *, {, }, \, :, <, >, ?, /, |, “ Check this one http://blog.jasonsamuels.net/post/22390717928/avoid-special-characters-in-your-sharepoint-file or Which special Characters are not Allowed in SharePoint 2013 Files\Folders?
  2. what are your Web app general setting for browser file handling, if it is strict then change to permissive. http://thesharepointproject.com/2012/03/31/setting-browser-file-handling-permissions-on-sharepoint-libraries/
  • I will have my administrator check for the permissive setting. I have seen the page on special characters, but underscore and hyphen isn't listed as a problem.
    – Bob ONeill
    Commented Apr 8, 2015 at 17:11
  • check this one: support.microsoft.com/en-us/kb/905231/en-us explain about the _
    – Waqas Sarwar MVP
    Commented Apr 8, 2015 at 17:16
  • The underscores and hyphens are in the middle of the filename, like add_comment.html or add-comment.html
    – Bob ONeill
    Commented Apr 8, 2015 at 17:22
  • How you importing the files? what browser you are using? did you try different browser?
    – Waqas Sarwar MVP
    Commented Apr 8, 2015 at 17:47
  • I decided to rename all the files with underscore and hyphen and all is well. Just have some code to tweak. Just more work, but I've had enough of trying to figure how to make it work.
    – Bob ONeill
    Commented Apr 8, 2015 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.