10

Task list has email enabled on task assignment, tasks can be assigned to multiple people or groups. When I create a task and assign it to myself, I get mail. When I update the task to assign it to a group, I get mail but not the group. When I create a task and assign it to a group, I don't get mail.

The site and list are open to everyone in the organization. I've toggled the send email setting on the list. IT modified the Active Directory groups being used for notification to disable the "Require that all senders are authenticated" setting.

I have full control on the sites for my organization, but I do not have SharePoint admin access. The company's SharePoint admin moved on a few weeks ago and we don't yet have a replacement.

Suggestions?

ETA: I checked with IT and the lists are already security groups.

migrated from stackoverflow.com Jun 1 '11 at 17:24

This question came from our site for professional and enthusiast programmers.

  • 1
    Is this a SharePoint group, or AD group? If this is an AD group can you email the group from your email client? – Toni Frankola Jun 1 '11 at 17:40
  • It's an Active Directory group, and I can send mail to the group from Outlook. The groups being used are all for teams within the organization. – Karen Christenson Jun 1 '11 at 19:57
4

I had the same problem, but this solution worked for me

SP Designer WF Email doesn't go to SP Group

All you have to do is:

- Give everyone view acces to the group

Go to the Group Settings, then, set everyone on "Who can view the membership of the group?", click OK

- Add read permissions for the Sharepoint group to the site.

Just be sure to give "read" permissions for this group on the site and task list.

  • How do I add the sharepoint system as an accepted sender in Exchange? I tried to create a Mail-User account for no-reply@sharepointonline.com and add it as sender, but it doesn't work. What do I do? – bgmCoder Mar 14 '17 at 15:22
2

I've seen this happen when the group is not a Security Group, just a Distribution List. Sometimes DL don't even get resolved in the People Picker.

Please check with your AD admins and try to persuade them to make the group a Security Group if it's not. Could help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy