1

I am trying to configure app on my VM(virtual machine) SharePoint Foundation 2013, and i am stuck at creating Subscription Settings Service Application

This is a link I am follwoing to configure the app. but after i run command

$appAppSvc = New-SPAppManagementServiceApplication -ApplicationPool $appPoolAppSvc -Name AppServiceApp -DatabaseName MyDBName

i get error below as

Failed to connect to an IPC Port: the system cannot find the file specified

can anybody help me to understand or help me solving this with a solution

  • are you able to fix the issue, for me looks like you have problem with your SQL db server, what is sql version you are using? – Waqas Sarwar MVP Apr 9 '15 at 21:06
  • Not i couldn't fix this issue yet, I am using sql server 2012. also my doubt is does this happen because i am using VM do perform this.? since my DNS IP is not static ? – Akshay Randive Apr 13 '15 at 4:55
1

A few items you will want to validate:

  • You will want to ensure you have the SharePoint Services Timer and SharePoint Administration Service enabled, and set to automatic start. Likewise, you can manually start them from the command line using the following commands:

net start SPTimerV4

net start SPAdminV4


Additionally, the resource I've used to configure the App environment for SharePoint 2013 was the Microsoft TechNet Article on this item specifically.

As far as explicit items to confirm, if you are having issues enabling/activating the service:

Verify that you have the following memberships:

  • securityadmin fixed server role on the SQL Server instance.
  • db_owner fixed database role on all databases that are to be updated.
  • Administrators group on the server on which you are running the Windows PowerShell cmdlets.

An administrator can use the Add-SPShellAdmin cmdlet to grant permissions to use SharePoint 15 Products cmdlets.


Lastly, I am presuming you aren't utilizing SQL Server Express. There are limitations, which will prevent you from using the User Profile Synchronization Service, in conjunction with your SharePoint 2013 configured environment.

  • my SharePoint Administration Service was not started, however on starting this i again tried to setup the Subscription Settings and Proxy using following code $account = Get-SPManagedAccount myManagedAc $appPool = 'SubscriptionServiceAppPoolAc' $serviceApp = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPool -name "Subscription Settings Service Application" -DatabaseName "SP2013DEV-SubscriptionSettingsDB" $serviceAppProxy = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $serviceApp i get error:Failed to connect to an IPC Port: Access Denied – Akshay Randive Apr 13 '15 at 10:17
  • I have assigned securityadmin & db_owner membership to myManagedAc that i am using to setup Subscription Settings & Proxy – Akshay Randive Apr 13 '15 at 10:20
  • Finaly i was able to achieve it.by running SP management shell as Administrator and then executed the command. also i Changed logon for SharePoint Services Timer to local account which was previously Network Service, as I thought may be it doesn't have permission for sql db thanks @Quinn Johns. Its such a relief – Akshay Randive Apr 13 '15 at 11:22
2

Two things to check.

  • Make sure "Windows SharePoint Services Administration" & "Windows SharePoint Timer Services" is running on all server in the farm. check in service console.
  • check the SQL server if account under which you are running the script have proper permission to access it.

Also check the ULS logs for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.