1

We have an Sharepoint Online 2013. Yammer Embed is added to our site. In Firefox and Chrome it works swell, in IE it does not work.

On IE: When logging in the first time Yammer pops up an windows stating that it is trying to authenticate. Then a message appears stating that a webpage is trying to close the window. Whatever I do, I do end up at the same blue login button.

At some point (not sure when, why or how) it got beyond that and then told me that content could not be shown in an iframe but after clicking on the message it logs me straight in on Yammer. After resetting IE I was back on the blue login button. Colleagues who have not resetted their IE settings get the i-frame thing.

This behaviour occurs on all machines, even on vanilla VM's (windows 7-8.1-10) and using new O365 credentials (1 admin and 1 user) specifically created for this. Resetting my IE did not help (even though I think that to be superfluous on newly installed machines)

Any suggestions?

3

We had a similar situation with office 365 and yammer embed in IE 11. Enabling Protected Mode for the Trusted Sites Zone (Internet Options > Security > Trusted Sites > Enable Protected Mode) solved it. Apparently Protected Mode used to be on by default in IE but no longer is.

0

I presume you are not sending Accept-Language: en-US or not having a Yammer cookie of locale=en-US present (I think).

If you add English (United States) to IE via Internet Options->Languages it works. You can then remove that locale from IE as Yammer will have the cookie. Hope they fix the bug soon!!

More information at: https://social.msdn.microsoft.com/Forums/en-US/5f999e8b-dcc0-4571-91db-60679e102547/yammer-embed-feed-issue?forum=sharepointdevelopment

  • I got a confirmation from Yammer team. This is fixed. – Vinod May 23 '16 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.