0

I'm trying to create calendar events in SharePoint that, through workflow, send attendees the event invitation and give them the option to click a link to add it to their personal calendars. I've followed a number of tutorials for creating the link that is used to download the ICS file that exists in the email sent to users automatically via the workflow. However, every time I try and do this, I simply get an error message:

"Error - Cannot complete this action - Please try again."

I've seen a previous post from another user here at the following link:

Email outlook calender invite

I've tried the proposed solution, I've found the link reference being called in JS to prompt for the download of the ICS, but after following the instructions, the same error occurs. I've tried leaving in the curly braces, taking out the square brackets, checking my URL, etc. with no luck. I also tried commenting on that question, but it's admittedly old and I don't have enough points to comment on it apparently.

I've tried the following syntax with no success:

http://<site-url>/_vti_bin/owssvr.dll?CS=109&Cmd=Display&List=<LISTGUID>&CacheControl=1&ID=<ITEMID>&Using=event.ics

And

    http://sharepoint/sites/<Company Name>/HelpDesk/_vti_bin/owssvr.dllCS=109&Cmd=Display&List={<GUID>}&CacheControl=1&ID=[<ITEM ID>]&Using=event.ics&IsDlg=1

Except for the sharepoint/sites/<company name>/HelpDesk part, I just put in my own domain and reference to the calendar list, which makes it practically the same as the previous entry.

Could I please get some advice with this? Thanks in advance.

1

I've figured it out on my own using help from the following site:

http://weblogs.asp.net/wkriebel/106767

Which explains the proper syntax for referencing the ICS file which should be as follows:

http://[site name]/_vti_bin/owssvr.dll?CS=109?Cmd=Display&CacheControl=1&List=[ListGUID]&ID=[EventID]&Using=Lists%2fEvents/event.ics

And formatting the list GUID in the following format example:

%7bBC04E0B5%2dB290%2d4D5E%2dB95C%2d3F16087246EE%7d

Which involves using URL encoded characters throughout the entire string (unlike several examples which have you use characters like '-' or '{' in the string). Several other sites use examples that don't have the '?' in the site path which seem to be related to the link not working as well.

Anyway, thought I'd post it in case this can help someone else out or if I need to use this again and forget what I did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.