0

I have noticed that it's possible to manage permissions at an item level in folder lists (open a folder list, click on an item, go to 'shared with', then click 'advanced', and here you are).

Unfortunately, that doesn't seem to be possible with folders inside a regular list. When I go into a regular list, click on an item, go to 'shared with', the 'advanced' button simply isn't there.

Is there something I have to do in order to make it available ?

0

To enable unique permissions for list items you should follow

  1. Using the ellipse menu - Select Manage Permissions
  2. Then from ribbon click on - Break Inheritance
  3. Now remove the existing permission & Grant new permission

Note - When you click on "Stop Inheriting Permission" following popup will appear.

enter image description here

If you read it, it says LIST ITEM.

  • But isn't that how to get global permission management for all the list ? I'm not trying to set permissions on all the items of a list, I'm trying to set unique permissions on a single item from a list. I tried just breaking the inheritance on list level, but the 'advanced' button in the sharing settings for each individual item of the list still doesn't appear: the items themselves still inherits their permission from their list. – user3387633 Mar 30 '15 at 13:51
  • No, if you can do this for item level. See my updated screen shot. – Amal Hashim Mar 30 '15 at 13:53
  • Alright, thank you ! My guess is that the "Manage Permission" entry from the ellipse menu doesn't appear on my interface. I do have a "Shared with..." entry that shows a pop-up with the people having access to the item. In the folder lists, that pop-up has an advanced button that leads to the permission interface (where the ribbon has the 'break inheritance' button). In my regular list, that pop-up has no advanced button. I was fairly certain I was using Sharepoint 2013, but it might actually be Sharepoint 2010... I don't even know how to check that ! – user3387633 Mar 30 '15 at 14:01
0

I've found "a" solution the my problem, though it only allows me to set permission: it doesn't solve the fact that there's no button to access the permission interface for some items.

Despite the fact that the interface might not be accessible through a link, one can still directly get it through an URL.

http://mysharepoint.com/_layouts/15/User.aspx?List=%7B#{list_guid}%7D&obj={#{list_guid}},#{item_id},LISTITEM

  • Replace #{list_guid} by the list GUID.
  • Replace #{item_id} by the ID of the item.

And you're good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.