1

I will try to be as specific as possible.

I have deleted User Profile Service Application, and remade it many times. I think the first two times i Deleted the Synchronization first, and then the Application. (don't know if that matters)

Every time I Start User Profile Synchronization Service, it says Starting. When I go to Services and check FIM. FIM service says disabled. FIM Synchronization switches from disabled to automatic.

When I run the Powershell command.

     get-spserviceinstance | where {$_.TypeName -eq "User Profile Service"}

I get...

 TypeName                         Status           Id                                  
 --------                          ------           --                                  
User Profile Service             Online        d8d1bed3-11be-4e42-b95d-27923dd6f794
User Profile Service             Disabled      e9f685dd-0fab-4782-8a21-470c5fb6fb5f

After a few minutes Both FIM's are disabled, and the powershell script returns both Disabled. Central Admin will then show the Synchronization as Stopped.

1

If you want to remove all the instances and try fresh I recommend the following solution:

Deleted Service Application, Service Instance(s) Remain

This issue can also be resolved with following PowerShell Script:

============================================

# Loads the SharePoint 2010 PowerShell extensions 
Add-PSSnapIn Microsoft.SharePoint.PowerShell  

# Sets variable for User Profile Service Application: enter the name of your UPA in quotes, replacing the "UPA" example
$upa = Get-SPServiceApplication |?{$_.displayname -eq "UPA"}

# Sets variable for service instance: enter your User Profile Synchonization Service instance ID/GUID in quotes
# which can be found by running "Get-SPServiceInstance" in PowerShell manually and copying the ID
$profsync = Get-SPServiceInstance |?{$_.id -eq "382e333c-61f0-4107-ac5f-31aaf0a3aec3"}

# Sets variables for farm account and password: enter your password in quotes
$farmacctpwd = ConvertTo-SecureString -AsPlainText -String "Password1" -Force
$farmacct = (get-spfarm).defaultserviceaccount

# Sets variable for synchronization server: enter your server name in quotes
$syncServer = "SharePoint1"
if($profsync.Status -eq "disabled")
{
  Write-Host "Provisioning User Profile Synchronization Service"
  $upa.SetSynchronizationMachine($syncServer, $profsync.ID, $farmacct.LookupName(), $farmacctpwd)
}
else
{ 
  write-host "Profile Synchronization Service is"$profsync.Status
}

Share The outcome if this helps

  • What do you mean by variable for synchronization server? I used the IP address of the SQL Server instance when configuring the farm. Or are you asking for which server you want the Synchronization service to run? – Chris Mar 27 '15 at 16:51
  • SharePoint Server Which is running the Sync Services and UPA – Shafqat Balouch Mar 27 '15 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.