3

I have configured an excel document library to open in the browser.
The file was published to the document library.
The document library was set to open the file in the browser.

When the file is clicked, it makes an attempt to open the file in the browser but it returns an error message.

Unable to process the request.
Wait a few minutes and try performing this operation again.

What else is necessary to get the Excel file to open in the browser?Excel Open In Browser Error Message

1

If you have the excel Service enabled then this problem is most probably with ASP.NET Impersonation.

Solution:

Disable the ASP.NET Impersonation at the Server level and "SharePoint Web Services" level. Via: IIS > Authentication > ASP.NET Impersonation

https://support.microsoft.com/en-us/kb/2291790?wa=wsignin1.0

IF no ECS configured in the farm then check this

http://blog.armgasys.com/?p=133

0

I had the same problems with the Excel Services and found a solution for the office webapps for word and powerpoint also.

Follow the procedure below.

The problem was traced to SharePoint’s built-in URL redirection for various files types. Behind the scenes, SharePoint is attempting to redirect the Excel/Word/Powerpoint file to a common viewer component. We just needed to turn this redirection off.

Edit these 2 files serverfilespowerpoint.xml and serverfilesword.xml and serverfilesExcelServer.xml at the following location: Program Files/Common Files/Microsoft Shared/Web Server Extensions/14/TEMPLATE/XML

Comment out any lines with the file extension of "docx or doc" and "pptx or ppt" and "xlsx or xls "

For Example:

The file "serverfilesExcelServer.xml" should look like this

<?xml version="1.0" encoding="utf-8" ?>

<!– Copyright (c) Microsoft Corporation. All rights reserved. –>

<ServerFiles> 
    ***<!--<Mapping FileExtension="xlsx" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/>-->*** 
    <Mapping FileExtension="xlsb" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> 
    <Mapping FileExtension="xlsm" RedirectUrlTemplate="/_layouts/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate="/_layouts/xlviewer.aspx?new=1"/> 
</ServerFiles>

The file "serverfilesword.xml" should look like this

<?xml version="1.0" encoding="utf-8" ?>
<!-- Copyright (c) Microsoft Corporation. All rights reserved. -->
<ServerFiles>
    ***<!--<Mapping FileExtension="doc"  RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" />-->***
    <Mapping FileExtension="dot"  RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" />
    ***<!--<Mapping FileExtension="docx" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />-->***
    <Mapping FileExtension="docm" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />
    <Mapping FileExtension="dotx" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />
    <Mapping FileExtension="dotm" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" />
    <Mapping FileExtension="odt" RedirectUrlTemplate= "/_layouts/WordViewer.aspx?id=|0" NoGetRedirect="TRUE" CreateRedirectUrlTemplate= "/_layouts/CreateNewDocument.aspx?id=|0" />
</ServerFiles>

The same way for the "serverfilespowerpoint.xml" file edit the 2 lines in this file

--> -->

and save both the files.

Perform an IISReset and you will now be able to read and edit the files without any problems.

This will definitely work for you. Cheers and Njoy

  • I made the proposed change to the serverfilesExcelServer.xml file, however now it no longer makes an attempt to open the file in the browser. It just tries to open the file in Excel application. I would like to have the file open in the browser not in Excel. – casp Mar 27 '15 at 18:26
0

I know it is an old post but just come across this problem and resolved by

  • checking add-ons in ie .
  • enable SharePoint add -ons in toolbars and extensions.
0

I have encountered this problem lately and have tried all SP possible ways were claimed online. this issues has targeted dozen of users (not all). We are using SP2010 and don't have excel services (no license). tried IIS Reset, Scripts to change the open with client App instead of browser. the SC Featured Open doc with client app turned on, checked the library sittings....

The issue was when Service Desk pushed O365 products update it did some changes which push all excel docs to open on browser even the setting set to open with client app.

reach out to Service Desk and requested a repair or reinstall of O365 on those machines. so this has resolved it. I guess first check if any update has been applied to O365 products if yes, reach out to Service desk and request to repair one machine (reinstall O365).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.