0

I have made a list, made a copy of the NewForm and customized it by adding and removing certain fields to what I want.

I want a different subset of fields displayed in the EditForm, however when I open editForm to customize it in SP Designer, it appears different from the NewForm despite looking like the default NewForm in the Browser. No fields are displayed and I do not see how I would change my EditForm to adjust the displayed fields

How can I change which fields are visible for editing/updating an item?

My questions is similar to this one, but I do not understand the answer. Hide some fields from EditForm

1

The built in edit form works a bit different, it gets the fields dynamically from the list settings. That is probably why you see none.

In SPD create a new form, choose edit form. Edit this form and your fields will be there.

After your changes make the new edit form the default edit form.

Be sure not to delete the built in edit form though. This can cause problems sometimes.

1

I found the solution myself. It turned out if you open the form directly in advanced edit, the fields are not displayed, while if you open it normally (left click) and then go into advanced mode after (button in the ribbon) then there's no problem.

0

If you want to hide some fields in form, you can try using JavaScript. Add a JavaScript file to the page and add the following line in your code:

$('nobr:contains("FieldName")').closest('tr').hide();

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.