I'm trying to install SP1 on my SharePoint 2013. But when I run the .exe I got error while detection.

Do you have any ideas ?

I checked the OPatchInstall log, but I can't find anything because it's too huge.

Edit: Server is W2008R2. Only 1 server with SharePoint 2013 and SQL Server. Current version is : 15.0.4420.1017 (RTM). And I'm trying to install the kb2880552.

When I try to install March2013PU and October2013CU or directly SP1, I still got the same error "error occured while running detection process". I tried foundation updates and server updates, no luck.

When I use PowerShell to detect which product is installed, I got this two IDs : 9ff54ebc-8c12-47d7-854f-3865d4be8118 b7d84c2b-0754-49e4-b7be-7ee321dce0a9

These IDs refer to "Foundation 2013" and "Server 2013".

  • what is the error you get. – Manish Oswal Mar 25 '15 at 13:37
  • 1
    "Error while detection process" just after I accept the licence and press next – Nico Mar 25 '15 at 13:38
  • What version are you running on right now? RTM? How many servers in the farm? – Christoffer Mar 25 '15 at 13:41
  • is your win server 2008 R2 with SP1. and are you installing an update SP1 for your already installed Sharepoint 2013 – Manish Oswal Mar 25 '15 at 13:42
  • yes 2008R2 SP1, sp2013 already installed (edit question) – Nico Mar 25 '15 at 13:46

See the article How To: Detect the Installed SKU of SharePoint 2010 on MSDN. It has a list of GUIDs for each SKU:

BEED1F75-C398-4447-AEF1-E66E1F0DF91E: SharePoint Foundation 2010     
1328E89E-7EC8-4F7E-809E-7E945796E511: Search Server Express 2010       
B2C0B444-3914-4ACB-A0B8-7CF50A8F7AA0: SharePoint Server 2010 Standard    Trial 3FDFBCC8-B3E4-4482-91FA-122C6432805C: SharePoint Server 2010       Standard 88BED06D-8C6B-4E62-AB01-546D6005FE97: SharePoint Server 2010    Enterprise Trial D5595F62-449B-4061-B0B2-0CBAD410BB51: SharePoint       Server 2010 Enterprise BC4C1C97-9013-4033-A0DD-9DC9E6D6C887: Search      Server 2010 Trial 
08460AA2-A176-442C-BDCA-26928704D80B: Search Server    2010 
84902853-59F6-4B20-BC7C-DE4F419FEFAD: Project Server 2010 Trial     
ED21638F-97FF-4A65-AD9B-6889B93065E2: Project Server 2010       
926E4E17-087B-47D1-8BD7-91A394BC6196: Office Web Companions 2010

You can look for these within the registry key HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0\WSS\InstalledProducts.

You can also use the PowerShell command get-spfarm | select Products to output GUIDs for the installed SKUs.

For 2013 you can see the information about the SharePoint products installed under System Settings -> Manage servers in the farm

enter image description here

  • 1
    When I use PS command, it outputs two IDs : 9ff54ebc-8c12-47d7-854f-3865d4be8118 and b7d84c2b-0754-49e4-b7be-7ee321dce0a9. And I'm using SharePoint 2013, while in your answer you provides infos for SP2010. And it seems like both Foundation and Server are installed ... i don't understand – Nico Mar 25 '15 at 19:29

There is something wrong during the SharePoint installation. You need to repair SharePoint then extract SP1 again before installing it.

Regards, -T.s

  • Yes, that's possible. I would like to test installing each patche manually. But sadly, I was asked to stop this subject for now ... So I'll comeback later to give feedbacks. – Nico Mar 31 '15 at 8:30

Repairing your SharePoint should definitely will resolve your issue.

You check the following article from tech-net article.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.