0

We have been provided a site in SharePoint 2010 that has lists that have around 500,000 records.

Although the list are filtered for the user, so that who-so-ever views the list can see only his/her records. But now a new problem has come up.

When the users in the "Site Owners" group open the View, everything works fine for them but when users in "Site Members" or "Site Visitors" open the view, it shows them the following statement:
"This view cannot be displayed because the number of lookup and workflow status columns it contains exceeds the threshold (8) enforced by the administrator."

I read on various blogs, i can increase the threshold value, but at my own risk and increasing that will impact the performance of the SQL Server.

Please suggest what i can do to solve this?

Thank you.

1

You will need to split the view vertically, make more than one view and distribute the lookup/workflow columns between them so that you don't exceed the threshold. These views can be based on your audience. Increasing the threshold is a bad idea and should be avoided as much as possible.

Regards

  • Thank you for your reply. As I am fairly new to SharePoint and this is a live project: 1) So, i quite did not get the suggested solution. 2) Since this project has been running successfully till now (4 yrs), without any changes, how and why did it stop working, could you please suggest some reasosn for that as well? Thank you – animat089 Mar 24 '15 at 6:57
  • Please investigate the matter further by doing the following. 1. Check how many lookup columns are there by following the procedure explained over here [link]blog.tahoepartners.com/index.php/… 2. Try to remove one of the lookup column from the view and see if that helps. You can always add the column back to the view. If removing the column helps try adding a calculated column to the list that will contain the same information as the lookup column and add that to the view. Theoretically that should work. – Arsalan Shahid Mar 24 '15 at 15:43
0

I know this is a year ago, but I recently encountered this problem. And I thought I'd share my experience and save someone from frustration.

Although the solution above was good in telling me what was causing the problem, I still had to try and figure out where the problem is.

In my case, I copied an existing and working page that has a DataFormWebPart which shows a view of a form library. In that copy, I edited the filter on the DataFormWebPart to show a different set of forms. My testing worked until my user tried it and got the threshold error message. The threshold is higher for site collection admins, so I didn't get the error when I was testing the new page I created.

So I went to look for the cause of the threshold error message.

In Sharepoint Designer, I normally use Data View Tools > Add/Remove Columns, (on the ribbon) to check the columns included in my DataFormWebPart. Everything looked okay. There was not a single lookup column in the view.

Then I decided to check the Data Source Details. (If you do not have the Data Source Details window open, you can do so via a toggle button on the Options tab of the Data View Tools ribbon menu. Then on your Data Source Details window, click the name of your data source to bring up the properties popup window.)

On the Data Source Properties, I clicked the Fields... button and then I noticed on the Displayed fields section, it shows a number of form fields which are not shown in the Add/Remove Columns. So I tried removing all fields except those I needed to properly render my view. And that fixed it!

You probably would not need to remove all fields you do not use, but you certainly need to reduce the number of lookup-type fields

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.