0

i installing sp 2013 on win 7 sp1, sql 2012 when i run pre installation file, system show error Application Server Role, Web Server (IIS) Role: configuration error .

log file

2015-03-22 00:01:13 - Processor architecture is (9) 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - Common Startup 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup 2015-03-22 00:01:13 - Trying to remove the startup task if there is any. 2015-03-22 00:01:13 - C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\SharePointServerPreparationToolStartup_0FF1CE14-0000-0000-0000-000000000000.cmd 2015-03-22 00:01:13 - Error: Startup task doesn't exist. This is not a continuation after a restart. 2015-03-22 00:01:13 - Locating the following command line arguments file: 2015-03-22 00:01:13 - E:\PrerequisiteInstaller.Arguments.txt 2015-03-22 00:01:13 - Error: This file does not exist 2015-03-22 00:01:13 - Details of the current operating system: 2015-03-22 00:01:13 - Major version number of the operating system: (6) 2015-03-22 00:01:13 - Minor version number of the operating system: (2) 2015-03-22 00:01:13 - Build number of the operating system: (0X23F0=9200) 2015-03-22 00:01:13 - Major version number of the latest Service Pack: (0) 2015-03-22 00:01:13 - Minor version number of the latest Service Pack: (0) 2015-03-22 00:01:13 - Platform ID of the operating system: (2) 2015-03-22 00:01:13 - Product suites available on the operating system: (0) 2015-03-22 00:01:13 - Product type of the operating system: (0) 2015-03-22 00:01:13 - Product type: (1) 2015-03-22 00:01:13 - OS type: (0) 2015-03-22 00:01:13 - Configuring the application's property sheet... 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Windows Management Framework 3.0 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - PowerShellVersion 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\PowerShell\3\PowerShellEngine 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - 3.0 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - CTPVersion 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\PowerShell\3\PowerShellEngine 2015-03-22 00:01:13 - Could not find or unable to read CTPVersion key 2015-03-22 00:01:13 - The prerequisite above is already installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Microsoft .NET Framework 4.5 2015-03-22 00:01:13 - Reading the following DWORD value/name... 2015-03-22 00:01:13 - Install 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\Net Framework Setup\NDP\V4\full 2015-03-22 00:01:13 - The value is (1) 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - Version 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\Net Framework Setup\NDP\V4\full 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - 4.5.50938 2015-03-22 00:01:13 - A post release .NET 4.5 is installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Windows Identity Foundation (KB974405) 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\Windows Identity Foundation\Setup\v3.5 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - 6.1.7600.0 2015-03-22 00:01:13 - The prerequisite above is already installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Microsoft Sync Framework Runtime v1.0 SP1 (x64) 2015-03-22 00:01:13 - Reading version of the following file... 2015-03-22 00:01:13 - C:\Windows\assembly\GAC_MSIL\Microsoft.Synchronization\1.0.0.0__89845dcd8080cc91\Microsoft.Synchronization.dll 2015-03-22 00:01:13 - The version is... 2015-03-22 00:01:13 - 1.0.3010.0 2015-03-22 00:01:13 - The prerequisite above is already installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Microsoft SQL Server 2008 R2 SP1 Native Client 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - Version 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\Microsoft SQL Server\SQLNCLI10\CurrentVersion 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Windows Server AppFabric 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - ProductVersion 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\AppFabric\V1.0 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Windows Identity Foundation (KB974405) 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\Microsoft Identity Extensions\Setup\1.0 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - 2.0.1459.0 2015-03-22 00:01:13 - A higher version of the prerequisite above is already installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Microsoft Information Protection and Control Client 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Microsoft\MSIPC\CurrentVersion 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - 1.0.621.117 2015-03-22 00:01:13 - A higher version of the prerequisite above is already installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Microsoft WCF Data Services 5.0 2015-03-22 00:01:13 - Reading the following string value/name... 2015-03-22 00:01:13 - Version 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Wow6432Node\Microsoft\Microsoft WCF Data Services\5.0 2015-03-22 00:01:13 - The value is... 2015-03-22 00:01:13 - 5.0.51212.0 2015-03-22 00:01:13 - A higher version of the prerequisite above is already installed 2015-03-22 00:01:13 - Check whether the following prerequisite is installed: 2015-03-22 00:01:13 - Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB2671763) 2015-03-22 00:01:13 - Reading the following DWORD value/name... 2015-03-22 00:01:13 - IsInstalled 2015-03-22 00:01:13 - from the following registry location... 2015-03-22 00:01:13 - SOFTWARE\Wow6432Node\Microsoft\Updates\AppFabric 1.1 for Windows Server\KB2671763 2015-03-22 00:01:17 - Beginning download/installation 2015-03-22 00:01:17 - Created thread for installer 2015-03-22 00:01:17 - "C:\Windows\system32\ServerManagerCmd.exe" -inputpath "C:\Users\DucNA\AppData\Local\Temp\PreE5EB.tmp.XML" 2015-03-22 00:01:18 - Request for install time of Application Server Role, Web Server (IIS) Role 2015-03-22 00:01:18 - Install process returned (0X3EB=1003) 2015-03-22 00:01:18 - [In HRESULT format] (0X800703EB=-2147023893) 2015-03-22 00:01:18 - "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i 2015-03-22 00:01:19 - Request for install time of Application Server Role, Web Server (IIS) Role 2015-03-22 00:01:20 - Request for install time of Application Server Role, Web Server (IIS) Role 2015-03-22 00:01:21 - Request for install time of Application Server Role, Web Server (IIS) Role 2015-03-22 00:01:22 - Request for install time of Application Server Role, Web Server (IIS) Role 2015-03-22 00:01:22 - Install process returned (0) 2015-03-22 00:01:22 - [In HRESULT format] (0) 2015-03-22 00:01:22 - "C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319" 2015-03-22 00:01:23 - Request for install time of Application Server Role, Web Server (IIS) Role 2015-03-22 00:01:23 - Install process returned (1) 2015-03-22 00:01:23 - [In HRESULT format] (-2147024895) 2015-03-22 00:01:23 - Error when enabling ASP.NET v4.0.30319 2015-03-22 00:01:23 - Last return code (1) 2015-03-22 00:01:23 - Reading the following DWORD value/name... 2015-03-22 00:01:23 - Flags 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Updates\UpdateExeVolatile 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - PendingFileRenameOperations 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SYSTEM\CurrentControlSet\Control\Session Manager 2015-03-22 00:01:23 - Reading the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired 2015-03-22 00:01:23 - Error: The tool was unable to install Application Server Role, Web Server (IIS) Role. 2015-03-22 00:01:23 - Last return code (1) 2015-03-22 00:01:23 - Options for further diagnostics: 1. Look up the return code value 2. Download the prerequisite manually and verify size downloaded by the prerequisite installer. 3. Install the prerequisite manually from the given location without any command line options. 2015-03-22 00:01:23 - Cannot retry 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Windows Management Framework 3.0 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - PowerShellVersion 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\PowerShell\3\PowerShellEngine 2015-03-22 00:01:23 - The value is... 2015-03-22 00:01:23 - 3.0 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - CTPVersion 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\PowerShell\3\PowerShellEngine 2015-03-22 00:01:23 - Could not find or unable to read CTPVersion key 2015-03-22 00:01:23 - The prerequisite above is already installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Microsoft .NET Framework 4.5 2015-03-22 00:01:23 - Reading the following DWORD value/name... 2015-03-22 00:01:23 - Install 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Net Framework Setup\NDP\V4\full 2015-03-22 00:01:23 - The value is (1) 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - Version 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Net Framework Setup\NDP\V4\full 2015-03-22 00:01:23 - The value is... 2015-03-22 00:01:23 - 4.5.50938 2015-03-22 00:01:23 - A post release .NET 4.5 is installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Windows Identity Foundation (KB974405) 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Windows Identity Foundation\Setup\v3.5 2015-03-22 00:01:23 - The value is... 2015-03-22 00:01:23 - 6.1.7600.0 2015-03-22 00:01:23 - The prerequisite above is already installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Microsoft Sync Framework Runtime v1.0 SP1 (x64) 2015-03-22 00:01:23 - Reading version of the following file... 2015-03-22 00:01:23 - C:\Windows\assembly\GAC_MSIL\Microsoft.Synchronization\1.0.0.0__89845dcd8080cc91\Microsoft.Synchronization.dll 2015-03-22 00:01:23 - The version is... 2015-03-22 00:01:23 - 1.0.3010.0 2015-03-22 00:01:23 - The prerequisite above is already installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Microsoft SQL Server 2008 R2 SP1 Native Client 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - Version 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Microsoft SQL Server\SQLNCLI10\CurrentVersion 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Windows Server AppFabric 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - ProductVersion 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\AppFabric\V1.0 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Windows Identity Foundation (KB974405) 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\Microsoft Identity Extensions\Setup\1.0 2015-03-22 00:01:23 - The value is... 2015-03-22 00:01:23 - 2.0.1459.0 2015-03-22 00:01:23 - A higher version of the prerequisite above is already installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Microsoft Information Protection and Control Client 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Microsoft\MSIPC\CurrentVersion 2015-03-22 00:01:23 - The value is... 2015-03-22 00:01:23 - 1.0.621.117 2015-03-22 00:01:23 - A higher version of the prerequisite above is already installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Microsoft WCF Data Services 5.0 2015-03-22 00:01:23 - Reading the following string value/name... 2015-03-22 00:01:23 - Version 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Wow6432Node\Microsoft\Microsoft WCF Data Services\5.0 2015-03-22 00:01:23 - The value is... 2015-03-22 00:01:23 - 5.0.51212.0 2015-03-22 00:01:23 - A higher version of the prerequisite above is already installed 2015-03-22 00:01:23 - Check whether the following prerequisite is installed: 2015-03-22 00:01:23 - Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB2671763) 2015-03-22 00:01:23 - Reading the following DWORD value/name... 2015-03-22 00:01:23 - IsInstalled 2015-03-22 00:01:23 - from the following registry location... 2015-03-22 00:01:23 - SOFTWARE\Wow6432Node\Microsoft\Updates\AppFabric 1.1 for Windows Server\KB2671763 2015-03-22 00:01:27 - Opening log file 2015-03-22 00:01:28 - Opened action for user 2015-03-22 00:01:28 - C:\Users\DucNA\AppData\Local\Temp\prerequisiteinstaller.2015.03.22-00.01.13.log

1

I highly do not recommend you installing SharePoint 2013 on Windows 7 (SP1). You can find here the minimum software requirements for SharePoint 2013 : https://technet.microsoft.com/en-us/library/cc262485.aspx#section4.

| improve this answer | |
  • yes, but my machine is running with win7 sp1 – Nguyen Anh Duc Mar 22 '15 at 2:06
  • You are Free to use hyperv to use a virtual server for this – Sascha Mar 22 '15 at 12:16
0

Unfortunately, the log file you provided is a little long to digest. It is unrecommended to use Windows 7, but still usable. I'd suggest following the installation steps listed on the following site. It seems likely you haven't enabled one of the requisite windows features.

Likewise, if you want an easier method for installation, I'd advise using AutoSPInstaller. I've used it multiple times for installations (on Windows Server), but makes the installation a breeze.

I'm wishing you the best of luck!

| improve this answer | |
  • I installed all steps in your link but can not resolve this problem :( – Nguyen Anh Duc Mar 23 '15 at 1:46
  • Are you still receiving the same errors logged? – Quinn Johns Mar 23 '15 at 15:05
  • The biggest thing that your log indicates, is two scenarios; you have pre-requisites installed that are up-to-date (and newer), and likewise, you are missing multiple pre-requisites. – Quinn Johns Mar 23 '15 at 15:08
  • yes, same errors. – Nguyen Anh Duc Mar 24 '15 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.