I recently created a Sharepoint site (Record Center) for making a hiring portal. But I have an issue.

I am unable to delete all documents in one go from "default" library (renamed Job Applications).

1) I tried creating a workflow also, it did not work for me.

2) The only option left with me was deleting one by one (which is quite painful)

So, I cannot delete all files from default folder (Job Applications) but I can do the same in other Libraries created by me (because multiple selection of files is allowed there, like "Shortlisted Applications")

.enter image description here enter image description here enter image description here

  • multiple select option is missing in default library(Job Applications) Mar 20, 2015 at 12:02

2 Answers 2


thank you for all solutions. Well finally I was able to resolve the issue. The way I resolved is,q I create a new View and I got the option of multiple select ("Checkbox"). It worked and I was able to delete hundreds of documents in a single go.

thanks again !


Click on Modify view. Go to Tabular View section. Check : Allow individual item checkboxes

  • thanks Nadeem, but this doesnot work with this Default Library, "Allow individual item Checkboxes" option was by default checked (I re-checked and tested, still no success). Mar 20, 2015 at 13:53
  • Checboxes and Inline editing both works in other libraries but not this default one :-( Mar 20, 2015 at 13:54
  • Maybe some of the files are checked out or Approval Status is pending. Check-in the files which are checked-out and try to delete them or select only checked-in files and try to delete. Mar 20, 2015 at 16:40
  • thanks Shantha, but the question here is how to select multiple files, the checkbox (for selecting files) is missing even after we enable the feature (as discussed above). Check-in and Check out concept is also applicable but 90% ofthe files are uploaded by me (I am Admin and developer). Mar 21, 2015 at 11:29
  • @umesh, perhaps the page has been customised? Mar 21, 2015 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.