1

I get Access Denied while viewing asite collection from the browser.

I am site collection administrator and I can open an other site collection in the same content DB

I can do Get-SPSite from PowerShell, I tried to do iisreset (and also to restart the server).

Where the problem can be?

In the log I see this error:

Failure while fetching document

  • Is it publishing site? check from your central admin, if site is marked as locked? what type of authentication you are using? Close all browser and reopen it? try with different user ( make him as site collction admin from central admin) then try it. – Waqas Sarwar MVP Mar 20 '15 at 22:20
  • yes It s a publishing site. It is not locked. I am using Claim auth. I migrate a SP10 content db on that web application, I guess the problem is there – Nk SP Mar 23 '15 at 8:32
  • What about Object Cache Setting on the Web app as this is publishing portal – Waqas Sarwar MVP Mar 23 '15 at 12:20
0

Is it something on the home page?

Here's a quick test: navigate to (site collection url)/_layouts/settings.aspx

  • still AccessDenied. If I add the user to the User Policy for that application it works fine. But do not know why – Nk SP Mar 20 '15 at 12:15
0

The problem was quite strange.
My user account was twice in the web.SiteUsers set.
Once with the claims authentication i:0#.w|domainname\username and an other with classic authentication domainname\username.
I remove those users and then it worked fine.

I think I had this issue during the migration of the contentdb' users. (from 2010 to 2013)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.