4

In Sharepoint document library, i have uploaded many documents of different types MS word, excel and PDF. When i click on MS Word or MS Excel documents, they are opened in Microsoft Word or Excel applications. But when i click on PDF files, they are not opened in Adobe Reader application but they are opened in Internet Explorer instead. I want to change this behavior to open PDF files in Reader instead. How this behavior can be changed?

4 Answers 4

4

If the PDF files are opened in the browser, then it means you have either configured the Permissive mode in Browser File Handling, or added the PDF extension to the allowed MIME type list.

To have the PDFs opened in Acrobat, you should disable the Permissive mode (and set it to Strict mode) and if it is already Strict, then remove the PDF extension from the allowed MIME type list.

# set BrowserFileHandling property as Strict
$wa = Get-SPWebApplication <web-App-URL>
$wa.BrowserFileHandling = 'Strict'
$wa.Update()

# remove PDF from MIME type list
$wa = Get-SPWebApplication <web-App-URL>
$wa.AllowedInlineDownloadedMimeTypes.Remove('application/pdf')
$wa.Update()

Read more: https://www.sharepointdiary.com/2011/04/open-pdf-document-browser-sharepoint2010.html

4
  • I have changed it to "Strict" mode and then remove PDF extension from allowed MIME types. after that When i click on pdf document in document library, instead of opening in acrobat reader, it ask me to save as document. But i want to open it directly in adobe reader? how its possible
    – SPBeginer
    Apr 13, 2015 at 15:32
  • 1
    "this post" link is dead.
    – Jussi Palo
    Jun 21, 2017 at 6:33
  • @JussiPalo thanks, I've updated it with the new one
    – pholpar
    Jun 23, 2017 at 9:04
  • "this post" link is dead again.
    – Joe
    May 7, 2020 at 17:26
1

To make your PDF files to open using adobe reader application.You need to remove the allow mime types(

AllowedInlineDownloadedMimeTypes

) property of the web application. This is usually done via powershell and you need to be admin on the server. Please do check if the mime type is added to the existing web application before removing it.

$webApp = Get-SPWebApplication("http://webappurl")
$WebApp.AllowedInlineDownloadedMimeTypes.Remove("application/pdf")
$webApp.Update()

Please note that this will be a web application level setting and it might affect all sites under the web application.

For more detailed scenarios .Check this Microsoft wiki page to Broswer File Handling

2
  • The OP would like to open the PDFs in Adobe Reader, not in the Browser. Your answer is the oposite way, as far as I know. 'Inline' means: in the browser. See the link in my answer, please.
    – pholpar
    Mar 19, 2015 at 11:13
  • Apologies ! I have edited my answer here.
    – Arvi
    Mar 19, 2015 at 11:42
0

The easiest solution is to disable the Adobe reader add-on in Internet Explorer. That will force the PDF to open in the application instead of the browser. But, each individual user would have to do that.

0

Hkey_Current_User\Adobe\Acrobat Reader\11.0\Originals.
Create a Dword "bBrowserIntegration" with value: 0

The correct registry path (.reg file) is: - Windows Registry Editor Version 5.00 - [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\11.0\Originals] - "bBrowserIntegration"=dword:00000000

This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.