0

I am getting this error in my Application Page. I have also done EnableSessionState="true" EnableViewState="true" in the page directive.

Thanks

0

Instead of changing it in your page directives, do the changes in your web.config file. If you don't know where it is, open iis manager, go to the app pool web site, select it and click on browse (top right of the panel), it will open the folder containing your web.config file.

5
  • can you tell me what to write in web.config file. and where should i add it – Ishani Mar 19 '15 at 7:28
  • Find the enableSessionState and change it to true – KhalilG Mar 19 '15 at 7:30
  • I have tried to make it true... but giving Runtime Error – Ishani Mar 19 '15 at 7:36
  • <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" clientIDMode="AutoID" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7"> </pages> – Ishani Mar 19 '15 at 7:39
  • can you share the error message ? – KhalilG Mar 19 '15 at 13:31
0

Make sure that "ASP.NET Session State Manager Service" is running.Also , try executing following command in PowerShell :

Enable-SPSessionStateService -DefaultProvision

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.