0

I've got a Project server site that needs to access to the values of a list stored in the PWA when a new row is added in a list of its own.

For that I've created a workflow using Sharepoint Designer.

When I invoke ...PWA/_api/web/Lists('GUID') from that workflow I always get the same error: Unauthorized. Even making the call using "App Step".

But if I invoke that service directly from chrome it works fine.

Any idea which permission is needed or what is happening? I've been looking the permissions and found nothing unusual.

2
  • what account is the workflow running as? the app step will run as the author of the workflow.
    – Mike
    Mar 17, 2015 at 18:41
  • Hi @Mike, the workflow starts when a new row is added, so if I am correct the workflow will run with the account of the row adder user. I've tried with a user that has full control over the site and over the list.
    – ADPX
    Mar 18, 2015 at 8:26

1 Answer 1

0

I finally found the error. I needed to give full control permissions to the user that was running the workflow. Which I found using ULSViewer.

Hope it helps anybody else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.