0

Title Missing server side dependencies.

Severity 1 - Error

Category Configuration

Explanation [MissingWebPart] WebPart class [3417184e-0312-0308-7a02-a4b2ce7fa8aa] is referenced [6] times in the database [WSS_Content_Test], but is not installed on the current farm. Please install any feature/solution which contains this web part. One or more web parts are referenced in the database [WSS_Content_Test], but are not installed on the current farm. Please install any feature or solution which contains these web parts. [MissingWebPart] WebPart class [35aee725-be5b-7f5c-30f1-fb758cbc1310] is referenced [2] times in the database [WSS_Content_Test], but is not installed on the current farm. Please install any feature/solution which contains this web part. One or more web parts are referenced in the database [WSS_Content_Test], but are not installed on the current farm. Please install any feature or solution which contains these web parts.

Remedy For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=142689".

Failing Servers

Failing Services SPTimerService (SPTimerV4)

I have search the web and found many solutions but no one convinced me. looking for authentic and accurate solution? If any body have solved this issue then please share your experience?

0

This is typically because the web part exists on a page or is in the solution gallery. Most developers do not put in feature deactivation code to clean up any instances of the web part and remove it from the web part gallery. This is why these errors come up. They need to be removed for the error to be resolved.

In a 2007 to 2010 migration, we had to go through and remove all these references because we had a lot of third party web parts that were not able to be upgraded to 2010.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.