0

I can't open the Shared with function in Sharepoint list's. In document libraries everything works fine. Just not working in lists. Any ideas how to fix it? Sharepoint has all news updates.

Also if I'm creating the fresh new Web Application, and Site Collection, and in Site Collection a new "Custom list", the problem still remains.

The same problem on Sharepoint Foundation 2013, Sharepoint Server 2013 Enterprise and Standard.

You can check in youtube, whats happening.

https://www.youtube.com/watch?v=wiiFsmzbM28

2

this issue was introduced by update KB2899508. SO the way to fix it, you have to change the .JS files at 15 hive.

the problem is in sharing.js (production version) and sharing.debug.js (debug version). Both files can be found at \Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\LAYOUTS

sharing.JS, Change from

k.load(g,"ID","FileRef","FileLeafRef","Client_Title")

to:

k.load(g,"ID","FileRef","FileLeafRef","Client_Title","Title")

sharing.debug.js

change From

cctx.load(listItem, 'ID', 'FileRef', 'FileLeafRef', 'Client_Title');

to

cctx.load(listItem, 'ID', 'FileRef', 'FileLeafRef', 'Client_Title', 'Title');

I tested this and its works without any issue.

Note: make this change on all WFE and Peform IIS reset if after the change still having issue. https://social.technet.microsoft.com/Forums/office/en-US/c9703b7b-a719-48b4-9350-9d9a75ac62e1/list-item-shared-with-dialog-error?forum=sharepointgeneral

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.