0

I have a farm with user profiles and my sites configured.

There is a two trust between the two farms. When I am trying to start the user profile synchronization service I had to use the IP address of the domain controller as the name could be resolved and it kept saying LDAP server is unavailable.

The user profile service is working and the profiles have imported successfully.

  1. I edited the user profile properties to import the user photos which seems to be working now.
  2. When I edited the picture property and set the direction to export. The crawl showed success in the FIM logs for DC_export and the photos where not exported.

I have SSL certificates added to the web front ends. I have also configured AAM.

In the logs I get following errors:

  • Is there any article which details how to configure the MIISClient to check if the export property is actually being exported.

  • Is there any article which gives provides information if this issue is caused by SSL certificates.

    User Profile Application: SynchronizeMIIS encounters an exception: System.NullReference

        Exception: Object reference not set to an instance of an object.    
         at Microsoft.Office.Server.UserProfiles.UserProfileImportJob.<>c__DisplayClass2.
    
        <IsTimerJobRunning>b__1()  
           at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.
    
        <RunWithElevatedPrivileges>b__3()    
         at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated
    
    
        secureCode) 
            at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback
    
    
        secureCode, Object param)  
           at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated
    
    
        secureCode)    
         at Microsoft.Office.Server.UserProfiles.UserProfileImportJob.IsTimerJobRunning
    
        (UserProfileApplicationJob timerJob) 
          at Microsoft.Office.Server....  e14cf29c-3eae-0052-f803-6f87d11502318
    
    
    
        EditProprty::_BuilDSMappingList threw exception : System.IO.InvalidDataException: 
    
        Found invalid data while decoding.
             at Microsoft.Office.Server.UserProfiles.Synchronization.DSMLAttribute.get_Syntax()
    
         at Microsoft.SharePoint.Portal.UserProfiles.AdminUI.EditProperty._BuildDSMappingList
    
        (SortedList& attributes, Hashtable& propertyDefinitions, Boolean& fHasImports, 
        Boolean& fHasExports, Boolean& fHasImportFromSelectedConnection)  
    
        f74cf29c-0e66-0052-f803-6079ba0a6928
    
0

From SharePoint side

  • Open MIISCLIENT.EXE from C:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\UIShell
  • Look at the latest DS_EXPORT phase and click on "Updates" in Export Statistics, this would open the Object Details window
  • Choose the user for whom the picture was updated and click on Properties
  • You should see a change of type "add" for attribute name "thumbnailPhoto" as belowenter image description here

http://blogs.technet.com/b/nishants/archive/2012/02/21/how-to-sync-picture-from-sharepoint-to-active-directory-and-hence-to-outlook-and-lync.aspx

  • I am still fizzy about the using the IP address of the Domain controller – Waqas Sarwar MVP Mar 17 '15 at 13:14
  • Do you think I need to add the Active Directory Lightweight Directory Services |to the Application server on which the user profile is configured. rajeshg.me/2013/09/ldap-server-is-unavailable-in.html. Is this a recommended practice in a production environment. – user1339913 Mar 18 '15 at 8:51
  • I changed the IP address to the server name on the server connection page but the full synchronization shows 0 updates. – user1339913 Apr 9 '15 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.