2

I have several email-enabled document libraries on a SharePoint 2010 site. Per our security policy, they are set to "Accept e-mail messages based on document library permissions." Most emails successfully arrive in the library. About 40% of the emails fail. I have sent the same 5 emails to one of the libraries multiple times, each time anywhere between 1 to 3 of the emails failed to arrive and they were almost always different ones that failed. So there doesn't seem to be a pattern. It doesn't seem to matter if they have attachments, size of the attachments, or if they were received in a batch. There are just those that randomly fail.

The SharePoint log error reads as follows:

An error occurred while processing the incoming e-mail file c:\inetpub\mailroot\drop\8ebe650201d06012000000be.eml. The error was: Access denied. You do not have permission to perform this action or access this resource

Which is quite bizarre because most emails arrive successfully.

If I change the security settings to allow emails from any user, then I receive all the emails. unfortunately this is not an option. When I allow any user to email into the library, the Created By field reads as "System Account" for some and my username for others. Which tells me it doesn't recognize me as the sender for some. The others have my username.

The problem seems to be in the x-sender of the message. A successful email will have the following x-sender:

x-sender: me@company.com

A failed email will have the following: x-sender: prvs=3859DCC1A7=me@company.com

What I cant figure out is why Sharepoint (or outlook?) is prepending an ID to my email address. Has anyone seen this before?

Thanks,

Mike

3

It sounds like a misconfiguration of your Exchange environment. Are you using forefront protection with your exchange servers? There is a configuration for backscatter filters that will add that PRV= prefix to your sender address.

Because you can send one message and it had it and another that does not, it appears that it is not configured correctly on all servers that are transporting your message (i.e. some are configured and others are not).

  • Thanks Jesus. I will follow up with our sys admins and look into that. But assuming thats the case, if it were remedied then all outbound messages would have an x-sender that is prefixed. This would cause all emails from our domain into the document libraries to fail. Do you know of anyway around that? (aside from allowing any user to email into the libraries) – MikeInOak Mar 16 '15 at 22:32
  • the only way I know of (while keeping feature enabled) is to use domain exclusions from the backscatter rule. If your SharePoint address is configured as a different domain address you can exclude that. I don't believe there is a way to exclude only certain addresses. – Jesus Shelby Mar 16 '15 at 22:45
  • It was Exchange and with the advice you gave, our Sys Admin was able to fix the mail routing. Thanks for your help! – MikeInOak Mar 16 '15 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.