1

Since the update I've noticed that the managed metadata service is not working correctly anymore. The Term Store can be accessed via central admin, but not from site settings.

I've reset IIS, and set read permissions for the app pool service account (althought this was not set before, no issues had occurred). Still have not been able to access term store.

Update:

Error encountered in background cache check System.Security.SecurityException: Requested registry access is not allowed.

  • did you check the ULS logs or event log for more details? what error u getting? one more thing, if you un associated the MMS proxy from the web app and then re associate it. then test again – Waqas Sarwar MVP Mar 16 '15 at 15:37
  • Do you mean remove the proxy then recreate it? – MickB Mar 16 '15 at 16:00
  • I mean from Web app service connection...remove mms click ok....after that wait a min and again add it – Waqas Sarwar MVP Mar 16 '15 at 16:08
  • Tried your suggestion and it did not resolve it. Also tried recreating an entirely new MMS and it did not work either. – MickB Mar 16 '15 at 16:22
  • check this one. social.technet.microsoft.com/Forums/sharepoint/en-US/… you have to run the psconfig command line – Waqas Sarwar MVP Mar 16 '15 at 16:28
2

Looks like SPResourceSecurity not properly registered.

open cmd as administrator

type:

cd C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\BIN

then type:

psconfig.exe -cmd secureresources

Source: https://social.technet.microsoft.com/Forums/sharepoint/en-US/edf7946a-a178-46e8-b7f3-82f80ad4a194/have-anyone-set-up-mysite-on-a-frontend-server-and-userporfile-service-application-on-an-appserver?forum=sharepointadmin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.