0

I'm setting up an employee directory as seen on Marc's blog here http://sympmarc.com/2014/12/21/create-a-simple-sharepoint-2013-employee-directory-on-office365-part-1-introduction/.

The issue is that the office field won't come in. The ManagedPropertyMapping tag includes "OfficeNumber" but for some reason the ctx.CurrentItem won't pull back that particular field. I can do a search for "OfficeNumber: Vinings" for instance and it works correctly. I've spent hours trying to sort this out and I'm getting no where. Does anyone have any ideas?

Here is my ManagedPropertyMapping tag:

'AboutMe':'AboutMe','AccountName':'AccountName','Office':'OfficeNumber','Department':'Department','HitHighlightedProperties':'HitHighlightedProperties','Interests':'Interests','JobTitle':'JobTitle','LastModifiedTime':'LastModifiedTime','Memberships':'Memberships','PastProjects':'PastProjects','Path':'Path','PictureURL':'PictureURL','PreferredName':'PreferredName','Responsibilities':'Responsibilities','Schools':'Schools','ServiceApplicationID':'ServiceApplicationID','SipAddress':'SipAddress','Skills':'Skills','UserProfile_GUID':'UserProfile_GUID','WorkEmail':'WorkEmail','WorkId':'WorkId','WorkPhone':'WorkPhone','YomiDisplayName':'YomiDisplayName'

  • Have you tried using 'OfficeNumber':'OfficeNumber' instead of your current mapping? – Matthew McDermott Mar 14 '15 at 14:03
  • Thank you Mathew, and yes I have tried that as well. ctx.CurrentItem still won't pull it. – Anthony Bandoly Mar 14 '15 at 21:04
  • Return to the Result Type Rules page and see if you see a message about updating the Properties. It may be that additional processing is needed. Beyond that you can troubleshoot the JavaScript to find clues. – Matthew McDermott Mar 15 '15 at 13:22
  • Thanks again Mathew. For some reason I never get that prompt under "Search Result Types" or "Search Query Rules". – Anthony Bandoly Mar 17 '15 at 18:45
0

This problem was solved after multiple support calls with Microsoft. They told me they had other customer support tickets describing the same issue. After a few weeks of back and forth, the office field began to work just as expected. They claimed they didn't do anything on their end but I have my doubts since I had not touched the site. I wish I could post a more detailed and helpful solution, but in this case it just started working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.