2

I have DEV and PROD SharePoint 2010 Server environments. DEV is a copy of production a few months old. The User Profile configuration is, I believe, identical. Same sources, same FIM. However, the number of user profiles in Production is greater than that in DEV, even though the Profile DB used to create DEV's was copied and attached from PROD a few months ago. Production has around 3000 users, DEV is around 70 users short at 2930.

I did a compare of the DEV/PROD users from respective PROFILE DBs and I'm not finding anything singular about those missing from DEV. They're from different domains. 35 of them are test accounts, which are interesting.

Any ideas? Thanks.

Scott

0

Couple of things to make sure:

  1. make sure their is no filter in place dev farm or same filter should use in dev as in Prod.
  2. Check the Connection setting, same domains & OU you are sync /importing from AD. Compare both Dev and Prod.
  3. Run Full Sync in Dev.
  4. Also Check if MySitedeletion job is disable on any of farm?
  • Thanks Waqas. I took a look at the Connection Filters, and noticed that they were a little different. Prod had userAccountControl set to Bit on equals and Filter 2, whereas DEV was set to Equals. I changed the filters but still getting the same results. – Scott Gordon Mar 16 '15 at 19:13
  • However, I checked each Connection's "Populate Containers" to see if they were set up consistently. When I query containers, in DEV I'm getting "The LDAP server is unavailable." All other settings (name, auto discover DC, WindowsAuth, the account used, port number) are identical in PROD and DEV. Any guidance here? Do I need to set something to allow communication? Ways to test? – Scott Gordon Mar 16 '15 at 19:16
  • same service account being used for the Connection or different account used for prod and dev UPS? – Waqas Sarwar MVP Mar 16 '15 at 19:37
  • is their any firewall on the servers? – Waqas Sarwar MVP Mar 16 '15 at 19:39
  • Ha, yeah, I'm having infrastructure match them up. Will report back. – Scott Gordon Mar 17 '15 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.