I am experiencing a frustrating issue when I try to check out a document for editing in one of our Sharepoint sites (running MOSS 2007, Office 2010, IE9, Win 7 32 bit SP1), when I try to open the document, I receive the following message: 'Object reference not set to an instance of an object.' and when I click OK, 'This document could not be checked out. You may not have permission to check out the document or it is already checked out or locked for editing by another user.' The second error is superfluous because none of those conditions are true. I believe this to be a local machine issue and not related to the SP server install. I checked the logging on our MOSS server and found the following error entry which I believe is related to my issue:

w3wp.exe (0x19D8) 0x3E68 CMS Publishing 8x0a High AppDomainUnloadListener.RegisterSelf() entered lock(this=64880701)


  • This MAY be resolved as I tried the next day and viola, it worked! Don't know what changed though...
    – Gryphoenix
    Commented Jun 1, 2011 at 13:44
  • Not the case. As randomly as it started working, it stopped working again.
    – Gryphoenix
    Commented Jun 1, 2011 at 14:20
  • Exactly the same happens to me but we don't have enabled the HTTPS protocol :S It is an environment issue for sure as it only happens in some machines and works in others ... Commented Jan 14, 2016 at 14:43

1 Answer 1


I figured out my problem and it was a little thing. The whole time I was receiving this error, I was connected via HTTP and not HTTP*S*! Once I connected using HTTPS, I could check out documents just fine. Boy that's frustrating!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.