0

I'm a site owner for a portion of our inward-facing SP site. I inherited a structure that was less than optimal. Most of the content is written up as webparts that were stored in All HTML Data (I'm in the process of developing a migration plan to bring the site structure into something better).

Until my larger project of moving content into SiteAssets (e.g.) is finished, I'm maintaining this older structure and am experiencing some odd behavior relative to URLs. Note that I'm using Word 2010 as the webpart editor.

When I try to change a hyperlink, I will paste into Word's hyperlink editor a value like 'https:/blah.company.com/SourceData/Welcome.aspx', and Word correctly returns that address when I mouseover the link within Word. However, when I save the page back to the server, the link is being rewritten to 'https://blah.company.com/SiteAssets/Welcome.aspx'.

I don't want that URL rewrite to happen. Is there a way to get one of these platforms to do only exactly what I tell it to do? And, what exactly is doing the rewriting here?

0

I finally sussed out the issue. The option that was causing the problem is in Word, not SharePoint. To disable this feature in Word (2010):

  • File > options > Advanced
  • Scroll down to the General section
  • Click the Web Options... button
  • Click on the Files tab
  • Deselect "Update links on save"
  • Click OK twice

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.