0

Users with correct permissions are suddenly unable to to edit documents. When a document is clicked it is opened in Read-Only mode stating that the document is checked out to literally "Another User". Performing an IISReset solves this issue for the time being. Also, some users are unable to open documents. The solution to this that i've found is clearing MS office local cache. I am able to solve these issues with the resolutions I have stated above, but the problems seem to return over time. Has anyone experienced this that has a solution to this problem? Or can anyone suggest possible causes that I could diagnose?

0

This might be because when a document is opened by a client program, Windows SharePoint Services puts a write lock on the document on the server. The write lock times out after 10 minutes. Users cannot modify the document during the time when the document is locked.

I think this KB article can help you: http://support.microsoft.com/kb/899709

............................................

You Can try this solution:

When User clicks Edit in Microsoft Word in a SharePoint document library Word launches and tell SharePoint that a document is opened for editing (locked for other users) A copy of the document is downloaded and stored in a hidden system folder on your local computer. By default, this is located in:

C:\Documents and Settings\UserName\Local Settings\Temporary Internet Files\Content.MSO

Normally, when you close the Office product, the file is removed from the Content.MSO folder If someone occurs that prevents the document from cleaning itself up(such as Network connectivity Lost etc.,) , it is possible that Office will continue to tell you the file is locked for editing.

The solution to the problem is to simply delete all the files out of the Content.MSO folder and attempt to open the document again from SharePoint.Make Sure U take backup before deleting :)

Let me know the results....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.