1

I have come across an unusual issue. We have SSL Offloading and Load Balancing using F5. This all works fine for both external and internal client requests, but now I find I wish to have the WFE's reference themselves (127.0.0.1) when loading pages while on the specific WFE.

Right away, I looked at the Alternate Access Mappings (AAMs) for our SharePoint 2010 farm. It was set for all requests to point to the default, SSL-secured version:

Internal URL: https://site.mydomain.com<br>
Zone: Default<br>
Public URL for Zone: https://site.mydomain.com<br>

Internal URL: http://site.mydomain.com<br>
Zone: Default<br>
Public URL for Zone: https://site.mydomain.com

Now, obviously my first thought was to change the Public URL for the http:// entry to point to HTTP: directly:

Internal URL: http://site.mydomain.com<br>
Zone: Default<br>
Public URL for Zone: http://site.mydomain.com

This seems to have broken the ability for document libraries to expand/collapse groups for some reason. I reverted it back for now.

I still need to find a way to have local WFE's point to themselves when attempting to load pages though. Does anyone know what method I can use to allow for this? I have disabled loopbacks on both WFE's already using the following blog entry for guidance: http://blogs.technet.com/b/sharepoint_foxhole/archive/2010/06/21/disableloopbackcheck-lets-do-it-the-right-way.aspx

1 Answer 1

0

Add an additional zone to the web app and configure the AAM for the new zone. You can specify different bindings to allow access via http.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.