I'm installing a Farm Solution on 2013 the following way

Add-SPSolution path/to/solution.wsp
Install-SPSolution -Identity solution.wsp -GACDeployment -Force
Enable-SPFeature -Url $site.Url -Identity solution_feature

The Solution will be installed globally, and the feature will activate a Timer Job as soon as it's activated.

I installed it the first time, everything was ok. But I needed to change something. -> New Development (VS2013) Publish -> generate new .wsp file -> Deactivate Feature, Uninstall Solution, Remove Solution and reinstall the same way as described.

But even though I war removing the old solution, I did an iis reset and restarted OWS Timer Service, after installing the new wsp, it still kind of installs the old version.

I have the feeling it always installs the same .dll file to the GAC.

What could I do wrong?

The only way I found to get rid of this behaviour is to create a totally new project in VS2013 and generate the .wsp file with the new project.

I can see pretty fast that the old solution is installed, because I renamed the Timer Job, but it still has the old name.

  • Did you try to remove the timer job manually and reinstall the wsp file ?
    – KhalilG
    Commented Mar 10, 2015 at 9:36
  • I removed the Timer Job by Disabling the Feature, and already tried to use PowerShell, as well as the Central Administration (and the buttons) to uninstall the solution and retract it from the system.
    – Loki
    Commented Mar 10, 2015 at 9:38
  • 3
    Did you open a new PowerShell session?
    – thomius
    Commented Mar 10, 2015 at 10:04
  • ... That was the solution. I need to open a new PowerShell session. I didn't even need to reinstall the solution. The only thing I did in the new session was activate Feature and it worked. Thank you. If you create an answer as well I can accept this
    – Loki
    Commented Mar 10, 2015 at 10:09

4 Answers 4


Open up a new PowerShell session (easy way to make sure PowerShell does not use cached old dlls)


Try to clear the configuration cache referenced by this link : http://blogs.msdn.com/b/jamesway/archive/2011/05/23/sharepoint-2010-clearing-the-configuration-cache.aspx

  • I did as described. Still, the "old" solution is installed :(
    – Loki
    Commented Mar 10, 2015 at 9:57
  • I may say something obvious but in your new dev steps description, it seems that you forget to mention the build (or rebuild) operation. I'm not sure if publishing the wsp rebuilds your solution.
    – KhalilG
    Commented Mar 10, 2015 at 10:00
  • I always rebuild before publishing
    – Loki
    Commented Mar 10, 2015 at 10:02
  • Try to use -Force when you activate your feature.
    – KhalilG
    Commented Mar 10, 2015 at 10:32

I think there is an error during removing Your old solution. Try to watch in "|entral Administration"-> "System" or something-> "Farm solutions"-> click on Your solution and see if no errors during retract. Select web application manually(by default there is "All web applications"), and Retract solution manually. Then Delete solution and iisreset.

You can use Event viewer(eventvwr.exe) and ULS Log viewer for log details. Also You can try to debug retracting process in VS if is installed on same machine

  • No error occured
    – Loki
    Commented Mar 10, 2015 at 9:58

Just restart "SharePoint Services Timer" windows service to apply new dll. Use cmd.exe:

net stop SPTimerV4
net start SPTimerV4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.