0

I am trying to create a new community site as a subsite to a host-headed site collection.

I've specified name, valid URL, community Site template and to use the same permissions and navigation as the parent. when I click create I get this error message:

enter image description here

This site collection already has a blog subsite which cas crated with no problems. The only customisation that has been performed on the site-collection is the use of a custom masterpage and stylesheet.

I've tried altering the web.config file in the way the error message suggests and it had no effect. There are no new events in the Event Log after attempting the create.

Does anyone know why this is happening and how to fix it?

Update: It appears that I only get this error when creating subsites with the Community Site template. This suggests a missing dependancy but I have activated both Sharepoint Server Standard Site Collection Features and Community Site Feature. Is there anything I've missed?

0

Your best option is to display the actual error message.

Which version of SharePoint are you using, because there are more than one web.config files.

Apart from the usual file in Inetpub\wwwroot\wss\VirtualDirectories, make sure you check the file in %ProgramFiles%\Common Files\Microsoft Shared\web server extensions\14\CONFIG.

Obviously, if you have multiple servers and a load balancer you need to modify the web.config files in all the servers.

Take a look at Working with Web.config Files for more information.

0

Answering my own question because I need space to post an update:

I 've managed to track down the correct web.config file and view the error message:

Server Error in '/' Application.

0x8107058aException has been thrown by the target of an invocation.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: 0x8107058aException has been thrown by the target of an invocation.

Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below

[COMException (0x8107058a): <nativehr>0x8107058a</nativehr><nativestack></nativestack>Exception has been thrown by the target of an invocation.]
   Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) +0
   Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) +290

[SPException: Exception has been thrown by the target of an invocation.]
   Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx) +146
   Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) +889
   Microsoft.SharePoint.SPWeb.ProvisionWebTemplate(SPWebTemplate webTemplate, String webTemplateToUse, SPFeatureWebTemplate featureWebTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) +1032
   Microsoft.SharePoint.SPWeb.ApplyWebTemplate(SPWebTemplate webTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) +532
   Microsoft.SharePoint.ApplicationPages.TemplatePickerUtil.ApplyWebTemplateAndRedirect(SPWeb Web, String strWebTemplate, Nullable`1 bSharedNav, Boolean bOnTopNav, Boolean bOnQuickLaunch, Page page, Boolean bDeleteOnError, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) +2068
   Microsoft.SharePoint.ApplicationPages.NewSubwebPage.BtnCreateSubweb_Click(Object sender, EventArgs e) +861
   System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +146
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3586

Looking at the stack trace it seems to be hanging up when it comes to apply the site template to the new subsite, possibly because of a missing dependancy but I have no idea what that might be. any help would be appreciated

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.