5

I am getting the following error when attempting to open a document library in explorer view:

"We're having a problem opening this location in File Explorer. Add this web site to your Trusted Sites list and try again."

The error seems to be only affecting site collections OTHER than the root site collection. As a workaround I have tried to use an URL like "\yourportal.com@SSL\DavWWWRoot\" but it is sporadic because the WebClient service crashes after two minutes. Other errors you may receive are

"Cannot find file "\yourportal.com\" Verify the path or Internet address is correct."

enter image description here

Can anyone give some hint on how to proceed to identify the root of the problem?

12

I think the Desktop experience feature is not installed and Web client service might be not started so try to follow this

  • Open Server Manager –> Manage –> Add Roles and Features.
  • Select Features from the left step navigation –> User Interfaces and Infrastructure –> Desktop Experience.
  • Click Next then Install.
  • Restart Server. Go to Services by clicking Run –> Services.msc –>

  • Start WebClient Service. Go back to your document library it's should be working.

Ref: WE’RE HAVING A PROBLEM OPENING THIS LOCATION IN FILE EXPLORER, ADD THIS WEB SITE TO YOUR TRUSTED SITES LIST AND TRY AGAIN

1

Within SharePoint Central Admin, the Explicit Managed paths for the defined site collections were missing a root site collection. For example, division/home was missing the /division site collection thus explorer view could not open the path.

Add the additional Explicit inclusion managed path(s) and then add the corresponding root site collection(s).

enter image description here

enter image description here

1

If you are using IE, go to Internet Options > Security > Local intranet > click on "sites" > Advanced > add the website to the zone. You may be have to reload IE to take effect.

  • Good point, this is very important and should be done first. Group policy can add this also. – ohio_tech Mar 6 '15 at 14:40
  • How could it be done by Group Policy? – KhalilG Mar 6 '15 at 14:45
  • Hi @KGahbiche - this was a bit broader answer than a quick reply so I posted this Q&A - sharepoint.stackexchange.com/questions/134437/… – ohio_tech Mar 6 '15 at 15:27
0

You can find this in CA / application management. Highlight the application with the trouble and click managed paths in the ribbon after it becomes active. If the problem is occurring in sub-folders use wildcard instead of explicit. If you are adding a wildcard, you may have to delete if there's already an explicit path defined.

0

In case you are using Windows Server 2016 and you want to connect to your SharePoint sites using the Explorer mode, there are big chances to encounter “We’re having a problem opening this location in File Explorer.” warning message. That’s because the WebClient windows service (responsible for the “translation” into Explorer mode) is by default not installed with the Windows Server 2016 OS. The same story was also on Windows Server 2012 and Windows Server 2012 R2 (and the fix was to activate the “Desktop Experience” feature from the Server Manager console).

This time (in case of Windows Server 2016), in order to get the WebClient windows service you need to activate the “WebDAV Redirector” feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.