0

I have run into a problem with SharePoint that is frustrating my users to no end. I have a large list (>5000 rows) that users can arrive at by clicking links formatted like this

http://my.farm.com/mfg/MySite/Lists/PLOT%20Compliance%20Exception/OpenIssues.aspx?FilterField1=Area&FilterValue1=DRY%20ETCH

However once they click on that and get to the view, they are not able to add any more filter options manually. If they click on a column (all the columns are indexed) header they get a cryptic error message like this:

Exception from HRESULT: 0x80131904<br/><br/>Correlation ID:abc5ef9c-08bb-d0a2-a96a-efc6c7c0418d<br/>

However, if I visit the same base view (show below) without any filters in the URL I can then manually add all the filters that were in the previous URL. The base view always returns < 5000 rows so the large list limit shouldn't affect it.

http://my.farm.com/mfg/MySite/Lists/PLOT%20Compliance%20Exception/OpenIssues.aspx

Is there any way to craft a URL that will filter the view AND allow the user to modify it further without triggering errors?

  • Are they trying to add filters to the column "Area" or is it any column? Have you tried to access the same url as a sitecollection administrator? – Christoffer Mar 5 '15 at 14:09
  • You should check the correlation ID in the logs – Nadeem Yousuf Mar 5 '15 at 14:32
  • I am an SCE and get the same errors. I don't think I have access to the logs, but I'll ask around. – Matt Mar 6 '15 at 17:18
0

I eventually solved this by adding this to the link

#InplviewHashfda8118a-f32f-48f1-8782-f48da3428ba7=

With causes SharePoint to remember the settings as the user adds more filters, where fda8118a-f32f-48f1-8782-f48da3428ba7 is the list id. So a complete url would be

http://my.farm.com/mfg/TrecMan/Lists/PLOT%20Compliance%20Exception/OpenIssues.aspx#InplviewHashfda8118a-f32f-48f1-8782-f48da3428ba7=FilterFields1%3DStatus-FilterValues1%3DAssigned%253B%2523Created-FilterField2%3DArea-FilterValue2%3DWET%2520PROCESS

If I remember correctly the parameters also needed to be double encoded which made things extra annoying.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.