0

I'm following this blog http://sharepointologic.blogspot.in/2013/04/branding-sharepoint-2013-my-sites-with.html and can't seem to get the feature stapler at the Farm scope to staple the site scoped Event Receiver to personal mysites. The host mysite collection gets the new master page but none of the personal mysites do.

My logs give some hint to this during the creation of the personal mysite:

Feature 'feature receiver guid' associated with Template 'SPSPERS#2' through feature 'farm scoped feature guid' is not installed in this farm, and cannot be added to this scope.

This indicates to me that the site scoped event receiver is not installed... but when I deploy via Visual Studio it says that the Deploy succeeded and there were no failures.

2

you have to give correct feature id. i had the same problem when i referred that post and almost worked for 2 days. now that you have already deployed, now even if you change feature id, it will not work properly. Now do the fresh project and provide correct feature id.

  • Well, I didn't put the words 'feature receiver guid' or 'farm scoped feature guid' literally in my Farm scoped feature, if that's what you mean. I used real guid from my receiver. Perhaps I'm misunderstanding you. – Brandon Runyon Mar 5 '15 at 12:56
  • Okay, I get what you mean now... I had the GUID of the Event Receiver in the farm scoped feature... what I needed was the GUID from the Feature that housed the Event Receiver!! Thanks!!! – Brandon Runyon Mar 6 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.