2

When I create one infopath form, I see this error:

A query to retrieve form data cannot be completed because this action would violate cross-domain restrictions.

If this form template is published to a SharePoint document library, cross-domain access for user form templates must be enabled under InfoPath Forms Services in SharePoint Central Administration, and the data connection settings must be stored in a UDC file in a data connection library in the same site collection.

If this is an administrator-approved form template, the security level of the form must be set to full trust, or the data connection settings must be stored in a UDC file by using the Manage data connection files option under InfoPath Forms Services in SharePoint Central Administration.

An entry has been added to the Windows event log of the server. Log ID:6932

Correlation ID:e692623b-fd86-4ba1-89a7-305fbda02762

I am using user account having administrator privilege.

0

Below are few suggestions to solve the same:

1)Ensure that the "Allow cross domain connection" setting in Central Admin is ticked.

2)If you are behind a proxy server, you will need to add this to your web.config of your SP web application:

<system.net>
<defaultProxy>
  <proxy proxyaddress="http://myproxy" bypassonlocal="true" />
  <bypasslist>
    <add address="mycustomwebservice.com" />
     </bypasslist>
</defaultProxy>

3)

  1. In the destination farm, download the respective udcx file from http://destination/udl library.
  2. Add an authentication element as per ‘http://msdn.microsoft.com/en-us/library/ms772017%28v=office.14%29.aspx

    <udc:UseExplicit CredentialType="NTLM">
    
        <udc:UserId>domain\username</udc:UserId>
    
        <udc:Password>Password</udc:Password>
    
        </udc:UseExplicit>
    
        <udc:SSO AppId="" CredentialType=""/>
    
    </udc:Authentication>
    

Also need to make sure that you have enabled 'Allow user form templates to use authentication information contained in data connection files' in Central Admin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.