1

I can't find any useful documentation on how to do this. I have 4.5.1 SDK installed on my development environment, but when I create a new sharepoint project I can only select 4.5:

4.5.1

4.5

Help is much appreciated!

EDIT:

This issue only seems to be affecting my SharePoint project templates. I can select 4.5.1 on other types of projects:

4.5.1classlib

  • Is this affecting only Sharepoint Project templates? Have you tried with other types of templates? – Ransher Singh Mar 4 '15 at 20:38
  • Yes, only SharePoint project templates. I can select 4.5.1 (among others) for other types of projects. – Chronozoa Mar 4 '15 at 21:31
0

Make sure you have installed the Microsoft .NET 4.5.1 Developer pack

https://support.microsoft.com/kb/2878632

It contains the .NET Framework 4.5.1 Multi-Targeting Pack which contains the reference assemblies needed to build apps that target the .NET Framework 4.5.1.

  • It is installed, as shown in my screenshot. I can create projects targeting 4.5.1, but not SharePoint ones. – Chronozoa Mar 4 '15 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.