0

Steps 1) Created a web application https://site.

2) Configured user profile ,search and metadata.

3) Created a Team site collection at the root i.e.https://site

4) Create a Explicit path at 'my'

5) Created a wildcard path at my/personal'

6) Created mysite host site collection at https://site/my/personal.

7) Configured Self Site Creation and set the path to https://sites/my/personal[%usersid%]

8) Under Setup my sites in User profile service application I have set the MySite Location to My/personal.

9) The user profile site collections are not created. I have enabled self site creation using the ui and powershell for the web application.

The my sites opens but the site collection for the user is not created. It points to https://site/my/personal/person.aspx

10) Set the thumbnailphoto property for the picture and ran a full synch

11) The import worked after 3 to 4 full synch

12) In MIISCLIENT.EXE when the sync runs it shows connections successful but o adds or deletes for the export.

  • do you have a top level site collection for the root '/'? – Mike Mar 3 '15 at 17:07
  • yes I have top level site collection at root'/' – user1339913 Mar 3 '15 at 17:32
  • Just a quick note: Make sure that your Content databases is not set to "offline" mode – Ulrich Bojko Mar 9 '15 at 13:02
  • And I assume the UPS service user should have at least write permissions (test it with db owner first) on the content DB. Check the ULS logs for potential errors when the my sites should have been created. – pholpar Mar 9 '15 at 19:30
  • why you are using 2 managed paths? it should only use 1. i.e my or personal. Change it in my site host setup in UPS – SharePointMan Mar 11 '15 at 5:09
2

Couple of steps required in order to configure the MySites.

  • Make Sure UPS & MMS are up and running.
  • Create a Web application and create root site collection with MYSiteHost template
  • in the Mysite Host location at UPA, give the root level site collection address
  • then set the permissions.
  • Enable Self-Service Creation

read more over here: http://sharepointgeorge.com/2010/configuring-my-site-sharepoint-2010/

  • Ups and MMS is working .I have set the mys ites permission. I have aslo enabled self service creation. I have set the mysite host location to personal. I have a site at the root i.e. a team site and a myssiteat site/my/personal – user1339913 Mar 3 '15 at 17:35
  • Is the root level site collection is mysite host and same url in the UPA's mysite host location? – Waqas Sarwar MVP Mar 3 '15 at 17:37
  • The root level site collection is site which is a team site. The mysite is site/my/personal .UPA's mysite host location is personal. – user1339913 Mar 3 '15 at 17:40
  • I think MySite host site should be root level of your Web Application other wise it will not work...so create "/" site collection with mysite host template. – Waqas Sarwar MVP Mar 3 '15 at 18:18
  • I can't remove the team site from the root site.It is one of requirements.Would it work if I add an explicit inclusion path say my and create the my sites under it. as suggested by this technet.microsoft.com/en-us/library/ee624362.aspx – user1339913 Mar 4 '15 at 9:36
1

You need to create a wildcard managed path named "/my/personal". Having your Personal site host in /my/personal is not a functional design. It should be the root site collection of your web application.

  • The Root site is a team site. I can't change the current design to the root site. The same setup worked when I installed it another environment . – user1339913 Mar 12 '15 at 10:36
1

I created the Mysites using a powershell script

 $site=new-object Microsoft.SharePoint.SPSite($MySiteRootURL);            
 try            
 {            
  $serviceContext = Get-SPServiceContext $site;            
  $upm = new-object Microsoft.Office.Server.UserProfiles.UserProfileManager($serviceContext);             
  if($upm.UserExists($Username) -eq $false)            
  {            
   Write-Host "User $Username was not found in the profile store." -f yellow;            
   return;            
  }            
  $userProfile = $upm.GetUserProfile($Username);            
  if($userProfile.PersonalSite -eq $Null)            
  {            
   Write-Host "Creating MySite for user $Username" -f darkyellow;            
   $userProfile.CreatePersonalSite();                  
   Write-host "Successfully created MySite for user $Username" -f green;            
  }            
  else            
  {            
   Write-Host "User $Username already has a MySite." -f darkgreen;            
  }            
 }            
 catch            
 {            
  Write-Host "Encountered an error creating a MySite for user $Username. Error:"$_.Exception -f Red;            
 }            
 finally            
 {            
  $site.Dispose();            
 }
0

Certainly Technet seems to suggest that this is achievable though I haven't seen it. Have you got a test farm which you can try things out on?

Anyway I think the issue is that the user profile service app doesn't have the right location as to where to create my sites.

I would do the following:-

Test config out in test farm first

Remove existing my site host site collection

Create new explicit manaGed path /my so you have https://site/my

Create my site host site collection at https://site/my

Check user profile settings for where users my sites are created default to /personal or in your config https://site/personal

My site host is changed to https://site/my/

Check that users have permissions in user profile service app to create a my site (manage permissions link)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.