0

I have a custom list in which I had set "Allow management of content types?" equals to "Yes", added content types as well. I set some of the columns in the list as Optional but still I can't see a few of them in my New Item/Edit Item Form. Am I missing something?

I think, if I set the column as "Hidden" then it should not visible in New Item but if it is "Optional", it should show in New Item form.

  • Are you using the standard NewForm.aspx and EditForm.aspx? – Patrick Mar 11 '16 at 8:04
1

As you are using Allow Management of content types your are grouping up the columns in a content type, so for each content type separate new form would be appeared .

For example

I have enabled Allow Management of content type

And columns are from two different content type like

1.Item

2.Holiday

so now two different set of columns are there , to create a new item you have to chose which set(Content type) you want to create the item

enter image description here

and if you are editing the item there also it would show a drop down of content type to chose

And while creating a column if content type is enabled then the column should be included in any of the content type , the add to all content type check box should be checked for the column to appear in new form enter image description here

  • It is still not working. I added a couple of new columns, still I can't see the new columns in the "New Item" form. – siraj Mar 3 '15 at 12:07
  • try to open the new form from Items in the ribbon, click the new item dropdown you could find all the content type and chose the one in which your column added, make sure you have checked the "Add to all content types" while adding new column – Anandakrishnan Mar 4 '15 at 4:07
1

I guess the column is not added to the default content type on the list. Make sure it is added because when you click on New Item, it opens the form against the default content type.

  • The column is added in default content list, still it is not showing the particular column in "New Item" form. – siraj Mar 3 '15 at 12:08
  • Can you double check if the newly added column is available under a default content type. Go to list settings -> Click on the default content type -> Verify the newly added column is listed under the columns. Also can you share the snap shot of the content type /columns under list settings. – Murali Krishna Golla Mar 3 '15 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.